media-tv/mythtv: multiple init script fixes
authorDoug Goldstein <cardoe@gentoo.org>
Mon, 14 Sep 2015 14:19:49 +0000 (09:19 -0500)
committerDoug Goldstein <cardoe@gentoo.org>
Mon, 14 Sep 2015 14:20:13 +0000 (09:20 -0500)
The new init scripts had a few bugs related to permissions and command line
switches.

Gentoo-Bug: 560142
Gentoo-Bug: 560144

Package-Manager: portage-2.2.20.1
Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
media-tv/mythtv/files/mythbackend.init-r2 [moved from media-tv/mythtv/files/mythbackend.init-r1 with 86% similarity]
media-tv/mythtv/mythtv-0.27.5_p20150904-r1.ebuild [moved from media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild with 99% similarity]

similarity index 86%
rename from media-tv/mythtv/files/mythbackend.init-r1
rename to media-tv/mythtv/files/mythbackend.init-r2
index e7bbeb186e9363838c8cf06ee56e7fdd85251651..43f53e876ff44d952ea0267980458499ce417011 100644 (file)
@@ -38,13 +38,13 @@ start() {
 
        # Work around any strange permissions that may be on these files.
        [ "x${MYTHBACKEND_LOGGING}" = "xfiles" ] && \
-               checkpath --dir --owner mythv:video --mode 0664 /var/log/mythtv
-       checkpath --dir --owner mythv:video --mode 0664 /home/mythtv
+               checkpath --directory --owner mythv:video --mode 0775 /var/log/mythtv
+       checkpath --directory --owner mythv:video --mode 0775 /home/mythtv
 
        ebegin "Starting MythTV Backend"
        start-stop-daemon --start --quiet --exec /usr/bin/mythbackend \
-                --pidfile /var/run/mythbackend.pid -- \
-               --daemon --pidfile /var/run/mythbackend.pid --user mythtv:video \
+                --pidfile /var/run/mythbackend.pid --user mythtv:video -- \
+               --daemon --pidfile /var/run/mythbackend.pid \
                --verbose ${MYTHBACKEND_VERBOSE} \
                ${logging} ${MYTHBACKEND_OPTS}
        eend $?
similarity index 99%
rename from media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild
rename to media-tv/mythtv/mythtv-0.27.5_p20150904-r1.ebuild
index 62926a852ba7d947085b2654c373f28283239cf3..05358ad15155ef073810e6ac2135b7a3dc4b5042 100644 (file)
@@ -275,7 +275,7 @@ src_install() {
        insinto /usr/share/mythtv/database
        doins database/*
 
-       newinitd "${FILESDIR}"/mythbackend.init-r1 mythbackend
+       newinitd "${FILESDIR}"/mythbackend.init-r2 mythbackend
        newconfd "${FILESDIR}"/mythbackend.conf-r1 mythbackend
        systemd_dounit "${FILESDIR}"/mythbackend.service