media-libs/alsa-lib: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 22 Feb 2020 22:11:23 +0000 (23:11 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 22 Feb 2020 22:11:39 +0000 (23:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-libs/alsa-lib/Manifest
media-libs/alsa-lib/alsa-lib-1.1.8.ebuild [deleted file]

index b4503372211f408ffaf18ecb8676edb6a16f218e..15b833a72a329eba9a3c3aa6577e71782e23b68e 100644 (file)
@@ -1,3 +1,2 @@
-DIST alsa-lib-1.1.8.tar.bz2 1002562 BLAKE2B a531ab501943924d007f7ae0e4489deea805ccbc8f2f02d3ee392aa2dbe54ffe31f58ee1744308f851a68f693c83125088708e901d0d83e4a7a5f644ef448aa3 SHA512 50ae107c6efe8200b4c41e0463e099d16e149332f1d3a22c3e81d3e7d980b7f93f3610fc9711ef62067caeb1054e7ea612ba3903bf8a91ebeffa48687cf80eed
 DIST alsa-lib-1.2.1.2.tar.bz2 1004129 BLAKE2B e8bf117f3036a32b020897f16b9648ac105c499f547ae157508720502722d4e1a651719c86a4e2756ca7a3c573a1f17c02524125ccaad12bcb8c7c71675c898a SHA512 e8286fd55f63ee0d95513279d0885c287533de89b7af6c338413dec5d38ba4f5a15da1a4a4ce36e052614e4b730e3778782dab9979d82958283be17b48604913
 DIST alsa-lib-1.2.2.tar.bz2 1030747 BLAKE2B 176054c7783452fcd0b30482f4d85fb88a1364a97f79830f2c22cd578275280fa64537d00a08f3e3b1420e4aeb4e4269c7523cb4296db3ed095bcf078b452726 SHA512 d21adb3ff998918c7d1820f9ce2aaf4202dd45ccb87cb092d49da8b2402b6ddaad06325be0fd59f17393a5d9958e3743bfccb4b14bdb947a42e7d791d73c7033
diff --git a/media-libs/alsa-lib/alsa-lib-1.1.8.ebuild b/media-libs/alsa-lib/alsa-lib-1.1.8.ebuild
deleted file mode 100644 (file)
index cb7eb79..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-
-inherit autotools multilib multilib-minimal python-single-r1
-
-DESCRIPTION="Advanced Linux Sound Architecture Library"
-HOMEPAGE="https://alsa-project.org/"
-SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="alisp debug doc elibc_uclibc python +thread-safety"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
-       doc? ( >=app-doc/doxygen-1.2.6 )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.1.6-missing_files.patch" #652422
-)
-
-pkg_setup() {
-       use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
-       # https://bugs.gentoo.org/509886
-       use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
-       # https://bugs.gentoo.org/545950
-       sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
-       default
-       eautoreconf
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               --disable-maintainer-mode
-               --disable-resmgr
-               --enable-aload
-               --enable-rawmidi
-               --enable-seq
-               --enable-shared
-               # enable Python only on final ABI
-               $(multilib_native_use_enable python)
-               $(use_enable alisp)
-               $(use_enable thread-safety)
-               $(use_with debug)
-               $(usex elibc_uclibc --without-versioned '')
-       )
-
-       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
-       emake
-
-       if multilib_is_native_abi && use doc; then
-               emake doc
-               grep -FZrl "${S}" doc/doxygen/html | \
-                       xargs -0 sed -i -e "s:${S}::"
-       fi
-}
-
-multilib_src_install() {
-       emake DESTDIR="${D}" install
-       if multilib_is_native_abi && use doc; then
-               docinto html
-               dodoc -r doc/doxygen/html/.
-       fi
-}
-
-multilib_src_install_all() {
-       find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
-       dodoc ChangeLog doc/asoundrc.txt NOTES TODO
-}