app-backup/borgbackup: fall back on bundled msgpack, bug #713820
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 29 Mar 2020 15:25:15 +0000 (11:25 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 29 Mar 2020 15:25:35 +0000 (11:25 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild [new file with mode: 0644]
app-backup/borgbackup/borgbackup-9999.ebuild

diff --git a/app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild b/app-backup/borgbackup/borgbackup-1.1.11-r2.ebuild
new file mode 100644 (file)
index 0000000..3b9d524
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/${PN}/borg.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+# Unfortunately we have a file conflict with app-office/borg, bug #580402
+RDEPEND="
+       !!app-office/borg
+       app-arch/lz4
+       virtual/acl
+       dev-python/llfuse[${PYTHON_USEDEP}]
+       dev-python/pyzmq[${PYTHON_USEDEP}]
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+"
+
+DEPEND="
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       dev-python/cython[${PYTHON_USEDEP}]
+       ${RDEPEND}
+"
+
+src_install() {
+       distutils-r1_src_install
+       doman docs/man/*
+}
index b326c5264e419ff1db835a612ef68b531881ce4c..3b9d5248820cd0cd5d080d570c83e8394e98b84a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1
 
@@ -28,7 +28,6 @@ RDEPEND="
        app-arch/lz4
        virtual/acl
        dev-python/llfuse[${PYTHON_USEDEP}]
-       dev-python/msgpack[${PYTHON_USEDEP}]
        dev-python/pyzmq[${PYTHON_USEDEP}]
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
@@ -40,14 +39,6 @@ DEPEND="
        ${RDEPEND}
 "
 
-BDEPEND="dev-python/pkgconfig"
-
-python_prepare_all() {
-       # allow use of new (renamed) msgpack
-       sed -i "s|'msgpack-python.*',||g" setup.py || die
-       distutils-r1_python_prepare_all
-}
-
 src_install() {
        distutils-r1_src_install
        doman docs/man/*