dev-ros/rosclean: remove patch merged upstream
authorAlexis Ballier <aballier@gentoo.org>
Tue, 7 May 2019 09:56:20 +0000 (11:56 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 7 May 2019 10:00:22 +0000 (12:00 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/rosclean/files/bb.patch [deleted file]
dev-ros/rosclean/rosclean-1.14.6.ebuild
dev-ros/rosclean/rosclean-9999.ebuild

diff --git a/dev-ros/rosclean/files/bb.patch b/dev-ros/rosclean/files/bb.patch
deleted file mode 100644 (file)
index e13668f..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-commit bbf1f945c7e3a54efca912d38fe8b1b2f5b63988
-Author: Alexis Ballier <aballier@gentoo.org>
-Date:   Thu Jan 22 09:56:41 2015 +0100
-
-    rosclean: Use "du -sk * 1024" on Linux for getting disk usage since "du -b" is not supported by busybox du, while "du -k" is supported by both coreutils and busybox.
-
-diff --git a/tools/rosclean/src/rosclean/__init__.py b/tools/rosclean/src/rosclean/__init__.py
-index 5dafb05..6f051f1 100644
---- a/tools/rosclean/src/rosclean/__init__.py
-+++ b/tools/rosclean/src/rosclean/__init__.py
-@@ -121,13 +121,13 @@ def get_disk_usage(d):
-     """
-     Get disk usage in bytes for directory
-     :param d: directory path, ``str``
--    :returns: disk usage in bytes (du -b) or (du -A) * 1024, ``int``
-+    :returns: disk usage in bytes (du -k) * 1024 or (du -A) * 1024, ``int``
-     :raises: :exc:`CleanupException` If get_disk_usage() cannot be used on this platform
-     """
-     # only implemented on Linux and FreeBSD for now. Should work on OS X but need to verify first (du is not identical)
-     if platform.system() == 'Linux':
-         try:
--            return int(subprocess.Popen(['du', '-sb', d], stdout=subprocess.PIPE).communicate()[0].split()[0])
-+            return int(subprocess.Popen(['du', '-sk', d], stdout=subprocess.PIPE).communicate()[0].split()[0]) * 1024
-         except:
-             raise CleanupException("rosclean is not supported on this platform")
-     elif platform.system() == 'FreeBSD':
index d5420ce90d5feffa1f4af48f9a78644889e0ccea..8910f969f5e9701d98815c29b19430db92855104 100644 (file)
@@ -19,4 +19,3 @@ RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        test? ( dev-python/nose[${PYTHON_USEDEP}] )
 "
-PATCHES=( "${FILESDIR}/bb.patch" )
index d5420ce90d5feffa1f4af48f9a78644889e0ccea..8910f969f5e9701d98815c29b19430db92855104 100644 (file)
@@ -19,4 +19,3 @@ RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        test? ( dev-python/nose[${PYTHON_USEDEP}] )
 "
-PATCHES=( "${FILESDIR}/bb.patch" )