net-mail/notmuch: Rename debug flag to valgrind (in testing ebuild only)
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Sat, 2 Jul 2016 09:27:20 +0000 (10:27 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Sat, 2 Jul 2016 16:11:56 +0000 (17:11 +0100)
Require valgrind only for build. 'debug' flag was actually misused.

Gentoo-Bug: 587560

Package-Manager: portage-2.3.0

net-mail/notmuch/metadata.xml
net-mail/notmuch/notmuch-0.22-r2.ebuild

index d476d7235ac28fb601ee5ad5d89296e093656634..332a3c073f59e24eb5338fbab5f9cbb48f93708a 100644 (file)
@@ -15,6 +15,7 @@
                <flag name="nmbug">Install experimental tag sharing /
                        pseudo-bug-tracking script for Notmuch
                        (see http://notmuchmail.org/nmbug/)</flag>
+               <flag name="valgrind">Depend on dev-util/vagrind for test suite</flag>
        </use>
        <longdescription lang="en">
                Notmuch is a system for indexing, searching, reading, and tagging large
index 41765a44695e2f943cf5a806bdbc80d269f0a8ce..6f415c85b7cae539973f50be1ec824c45432eed9 100644 (file)
@@ -22,9 +22,9 @@ KEYWORDS="~amd64 ~x86"
 REQUIRED_USE="
        nmbug? ( python )
        python? ( ${PYTHON_REQUIRED_USE} )
-       test? ( crypt debug emacs python )
+       test? ( crypt emacs python valgrind )
        "
-IUSE="crypt debug doc emacs mutt nmbug python test"
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
 
 CDEPEND="
        >=app-shells/bash-completion-1.9
@@ -35,7 +35,6 @@ CDEPEND="
        >=sys-libs/zlib-1.2.5.2
        sys-libs/talloc
        crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
-       debug? ( dev-util/valgrind )
        emacs? ( >=virtual/emacs-23 )
        python? ( ${PYTHON_DEPS} )
        "
@@ -45,6 +44,7 @@ DEPEND="${CDEPEND}
        test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
                >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
                crypt? ( app-crypt/gnupg dev-libs/openssl ) )
+       valgrind? ( dev-util/valgrind )
        "
 RDEPEND="${CDEPEND}
        crypt? ( app-crypt/gnupg )
@@ -99,7 +99,7 @@ src_prepare() {
 
        rm -f Makefile.config # assure that new Makefile.config will be generated
 
-       if use debug; then
+       if use test; then
                append-cflags -g
                append-cxxflags -g
        fi