dev-util/promu: Version bump to 0.3.0
authorManuel Rüger <mrueg@gentoo.org>
Sat, 2 Mar 2019 17:39:27 +0000 (18:39 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sat, 2 Mar 2019 17:39:27 +0000 (18:39 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
dev-util/promu/Manifest
dev-util/promu/promu-0.3.0.ebuild [new file with mode: 0644]

index 0b0d47242d64375b39994981ec4c9d4ee91635ab..66d840ecb4aeb43162c513f2e9994ac309e49745 100644 (file)
@@ -1 +1,2 @@
 DIST promu-0.2.0.tar.gz 1072026 BLAKE2B 2b68d992b37421d6b9a08cc9a9134f9ae52643d4c2844c8e1f6f6724f015582c99a8724ab6b8d1ee69437c660e3b972af85949e3221d8d8c709fd8c1a45e1256 SHA512 4da4716a9d4fb96b6016c9bd452fed0403721ab15f95e6955db2ab6e8e482f3bbb35cb4c1c94f690af9520729a93c100015ee48cb69627e129004ae0b15257ae
+DIST promu-0.3.0.tar.gz 366019 BLAKE2B 0e6e93bb573da0ef20947b72989d8a68a7d6d1490efc802acaee58c9f546e9b46162054172d445e4dcb5cbc33c152529f006edf3acc594b92927df0ab489f86a SHA512 543cb514fcab9700bc45cb1b4a9f056720af4acf8ed949e03445c2f4e52d89f6fb8eda3ee538bc92feb2dc06db31026bebad9bf6c86a6e37a0be294d17e4b518
diff --git a/dev-util/promu/promu-0.3.0.ebuild b/dev-util/promu/promu-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..ea82245
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="295a70a7f580b886572861b19545b28accfd4491"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.11"
+
+src_prepare() {
+       default
+       sed -i -e "s/{{.Revision}}/${EGIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+       pushd src/${EGO_PN} || die
+       GO111MODULES=on GOCACHE="${T}/go-cache" GOPATH="${S}" go install -v github.com/prometheus/promu || die
+       popd || die
+}
+
+src_install() {
+       dobin bin/*
+       dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}