sys-block/fio: add a configure flag to control rdma deps #542640
authorMike Frysinger <vapier@gentoo.org>
Wed, 1 Mar 2017 05:31:19 +0000 (22:31 -0700)
committerMike Frysinger <vapier@gentoo.org>
Wed, 1 Mar 2017 05:40:55 +0000 (22:40 -0700)
sys-block/fio/files/fio-2.2.15-rdma.patch [new file with mode: 0644]
sys-block/fio/fio-2.15.ebuild
sys-block/fio/fio-2.16.ebuild

diff --git a/sys-block/fio/files/fio-2.2.15-rdma.patch b/sys-block/fio/files/fio-2.2.15-rdma.patch
new file mode 100644 (file)
index 0000000..3ca9198
--- /dev/null
@@ -0,0 +1,52 @@
+From fd6d9c789bcb8b7c7b1edf34249e034094d341fc Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 28 Feb 2017 22:25:58 -0700
+Subject: [PATCH] configure: add a --disable-rdma flag to control rdma deps
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ configure | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index 15b87fac0e4c..187ac3583805 100755
+--- a/configure
++++ b/configure
+@@ -166,6 +166,8 @@ for opt do
+   ;;
+   --disable-numa) disable_numa="yes"
+   ;;
++  --disable-rdma) disable_rdma="yes"
++  ;;
+   --disable-rbd) disable_rbd="yes"
+   ;;
+   --disable-rbd-blkin) disable_rbd_blkin="yes"
+@@ -204,6 +206,7 @@ if test "$show_help" = "yes" ; then
+   echo "--esx                  Configure build options for esx"
+   echo "--enable-gfio          Enable building of gtk gfio"
+   echo "--disable-numa         Disable libnuma even if found"
++  echo "--disable-rdma         Disable RDMA support even if found"
+   echo "--disable-gfapi        Disable gfapi"
+   echo "--enable-libhdfs       Enable hdfs support"
+   echo "--disable-lex          Disable use of lex/yacc for math"
+@@ -642,7 +645,7 @@ int main(int argc, char **argv)
+   return 0;
+ }
+ EOF
+-if compile_prog "" "-libverbs" "libverbs" ; then
++if test "$disable_rdma" != "yes" && compile_prog "" "-libverbs" "libverbs" ; then
+     libverbs="yes"
+     LIBS="-libverbs $LIBS"
+ fi
+@@ -660,7 +663,7 @@ int main(int argc, char **argv)
+   return 0;
+ }
+ EOF
+-if compile_prog "" "-lrdmacm" "rdma"; then
++if test "$disable_rdma" != "yes" && compile_prog "" "-lrdmacm" "rdma"; then
+     rdmacm="yes"
+     LIBS="-lrdmacm $LIBS"
+ fi
+-- 
+2.11.1
+
index 1158dbdae902fc91c24c7ec0727cdc7317a119da..8080c1b7e603b0b165ffc1e3f0aa720ab79330ce 100644 (file)
@@ -40,6 +40,7 @@ S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
        epatch "${FILESDIR}"/fio-2.2.13-libmtd.patch
+       epatch "${FILESDIR}"/fio-2.2.15-rdma.patch #542640
        sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
        epatch_user
 
@@ -63,6 +64,7 @@ src_configure() {
                $(usex gtk '--enable-gfio' '') \
                $(usex numa '' '--disable-numa') \
                $(usex rbd '' '--disable-rbd') \
+               $(usex rdma '' '--disable-rdma') \
                $(usex static '--build-static' '')
        echo "$@"
        "$@" || die 'configure failed'
index c57607e80a28d92a333f2758c46876f01d0d2f55..64a01dc145fb37e0337c22927937c06479dc7bc0 100644 (file)
@@ -40,6 +40,7 @@ S="${WORKDIR}/${MY_P}"
 
 PATCHES=(
        "${FILESDIR}"/fio-2.2.13-libmtd.patch
+       "${FILESDIR}"/fio-2.2.15-rdma.patch #542640
 )
 
 src_prepare() {
@@ -66,6 +67,7 @@ src_configure() {
                $(usex gtk '--enable-gfio' '') \
                $(usex numa '' '--disable-numa') \
                $(usex rbd '' '--disable-rbd') \
+               $(usex rdma '' '--disable-rdma') \
                $(usex static '--build-static' '')
        echo "$@"
        "$@" || die 'configure failed'