dev-python/python-socketio: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:04:02 +0000 (22:04 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:11:18 +0000 (22:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-socketio/Manifest
dev-python/python-socketio/python-socketio-1.7.4.ebuild [deleted file]
dev-python/python-socketio/python-socketio-1.8.0.ebuild [deleted file]

index ba202b4bc76e0e757d4b73d207b129272fe94b2e..60fe47f533cd895347ac5ce70586abfb3ed3f43e 100644 (file)
@@ -1,3 +1 @@
-DIST python-socketio-1.7.4.tar.gz 23298 BLAKE2B a5337e6f124018172902fbc51935e193267a8e209e9d677fa52e72ff6b71ea27e2aa5284369082fe38013c5b4b21c8561952b9046acbfd3f02c824c0837b367c SHA512 fb31072420eca42fa0349f0a9350fe9ab6bbbac7dc32cd7ae76cffa026fdeeb4197b8c441d76bfc46af55a550c5b7e81e387b67d538c500075bc5b4e8f68d5ab
-DIST python-socketio-1.8.0.tar.gz 23557 BLAKE2B 085035d6621f2ec351b28095086c6cc5787c4466f904568d5ece0cf37261a75fb6793be1fedd9f54f7cbeccbb668eaee8463850698aa6f2a901b3454cf63f128 SHA512 2514cbad3e429c101f5e247bdf2e4a2b5a0957c19fa97e56ebe8cd78b36e81cfb9dc4500bee367e57460be3a08bbd1e70967a5c87109034ade847ff7f559711d
 DIST python-socketio-2.0.0.tar.gz 24180 BLAKE2B 33d0c2007acfe067264c670c98e2f8f6764a979b7c67d8d03217a3b2dc45dbccb699beeff151381f8ccd787610ad39bff3396d4737594ed467f29994b4b8f0a7 SHA512 285d6235aaa5914f21a883976ecf31e15947d28e396c859080cf418094e21b5f3a9c4de01361a2c3219edf43c3c587bca24c9f10ebb97be23bc12c59af79ee2b
diff --git a/dev-python/python-socketio/python-socketio-1.7.4.ebuild b/dev-python/python-socketio/python-socketio-1.7.4.ebuild
deleted file mode 100644 (file)
index acff4ee..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Socket.IO realtime server."
-HOMEPAGE="
-       https://python-socketio.readthedocs.org/
-       https://github.com/miguelgrinberg/python-socketio/
-       https://pypi.org/project/python-socketio/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       >=dev-python/python-engineio-1.2.1[${PYTHON_USEDEP}]
-       !dev-python/gevent-socketio"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-       )"
-
-# pypi tarball does not contain tests
-RESTRICT="test"
-
-src_prepare() {
-       eapply_user
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       esetup.py test || die
-}
diff --git a/dev-python/python-socketio/python-socketio-1.8.0.ebuild b/dev-python/python-socketio/python-socketio-1.8.0.ebuild
deleted file mode 100644 (file)
index 23df095..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Socket.IO realtime server."
-HOMEPAGE="
-       https://python-socketio.readthedocs.org/
-       https://github.com/miguelgrinberg/python-socketio/
-       https://pypi.org/project/python-socketio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       >=dev-python/python-engineio-1.2.1[${PYTHON_USEDEP}]
-       !dev-python/gevent-socketio"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-       )"
-
-# pypi tarball does not contain tests
-RESTRICT="test"
-
-src_prepare() {
-       eapply_user
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       esetup.py test || die
-}