sys-fs/cryptsetup: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 29 May 2020 08:51:04 +0000 (10:51 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 29 May 2020 08:51:18 +0000 (10:51 +0200)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/cryptsetup/Manifest
sys-fs/cryptsetup/cryptsetup-1.7.5-r1.ebuild [deleted file]
sys-fs/cryptsetup/cryptsetup-2.2.2.ebuild [deleted file]
sys-fs/cryptsetup/files/setup-1.7.0.py [deleted file]

index 07e55781c5d0fb08f6bcb4fd1563ac7dc0b4d409..bc14ac43704f13854d993d06c98001b493c2b0e5 100644 (file)
@@ -1,4 +1,2 @@
-DIST cryptsetup-1.7.5.tar.xz 1232696 BLAKE2B 1bd62b186564e0b902480d66f623074f8d2f06ea09f11788566e33d58f7d0dc8c79d5827e5966e1a20a5597c2cbdec76da49c8f54c0538a1ac3f869d8ef55456 SHA512 d473f7b06d705a3868a70f3767fafc664436b5897ba59025ea1268f815cb80a9076841ff9ff96cc130fb83ba18b03c1eee38cfaf1b471fdd883a3e126b771439
-DIST cryptsetup-2.2.2.tar.xz 10808684 BLAKE2B d8d864d9ec2a5d646706d3ba003a21aa83d2373ca7afed5663c5167172116ea9342704483559f49c06979cbe0f6ac5670f4e9baae88ab908423b793043ba4a68 SHA512 d04123a622438ecbee28145cbdc71886b6f13db87df1c67522bff6e6e3cba817e895e2d085bdb08c78f9cafba557b1203177811a0c316ccd9b7c19939f3fc851
 DIST cryptsetup-2.3.2.tar.xz 11037076 BLAKE2B b0f8a1a274e6b95b12aa7172dbdd41e512aea2c87a98d62b8b4d4cbb898b2d4b82e250368e385c4d4acc8e77046ea4b4f7be730750587569572c4b9490815bc1 SHA512 c5eb41751ca64ff906187f40805705570c261816b014dfcdbf2777f42e53668e32966197092a2235b8f6a7a4e7f9c3f301d82f17c45cfbcff96b9818631d7e5f
 DIST cryptsetup-2.3.3.tar.xz 11104768 BLAKE2B 54aa6f087c5366e843c1f9b649fd77ec8be8c4e65c783a2a84a036b4ef460c9d070bdd8aff72f87a7a3136f13581e84534940b435f0b49eb1951d1a755cab47a SHA512 d613efb80e003364a21832da3fefe3891d36a891119cc0efa970aad40ba135dfcd42b32a0c19c31ad879d4eddf27864beccbea1d4b31a47a4e075bc0f756365c
diff --git a/sys-fs/cryptsetup/cryptsetup-1.7.5-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.7.5-r1.ebuild
deleted file mode 100644 (file)
index 309bb43..0000000
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit autotools distutils-r1 linux-info libtool ltprune eutils versionator
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="https://gitlab.com/cryptsetup/cryptsetup/blob/master/README.md"
-SRC_URI="https://www.kernel.org/pub/linux/utils/${PN}/v$(get_version_component_range 1-2)/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
-# we don't support nss since it doesn't allow cryptsetup to be built statically
-# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} libressl nls pwquality python reencrypt static static-libs +udev urandom"
-REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
-       python? ( ${PYTHON_REQUIRED_USE} )
-       static? ( !gcrypt )" #496612
-
-LIB_DEPEND="dev-libs/libgpg-error[static-libs(+)]
-       dev-libs/popt[static-libs(+)]
-       sys-apps/util-linux[static-libs(+)]
-       gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
-       nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
-       openssl? (
-               !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
-               libressl? ( dev-libs/libressl:=[static-libs(+)] )
-       )
-       pwquality? ( dev-libs/libpwquality[static-libs(+)] )
-       sys-fs/lvm2[static-libs(+)]
-       udev? ( virtual/libudev[static-libs(-)] )"
-# We have to always depend on ${LIB_DEPEND} rather than put behind
-# !static? () because we provide a shared library which links against
-# these other packages. #414665
-RDEPEND="static-libs? ( ${LIB_DEPEND} )
-       ${LIB_DEPEND//\[static-libs\([+-]\)\]}
-       python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       static? ( ${LIB_DEPEND} )"
-
-#PATCHES=( )
-
-pkg_setup() {
-       local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC ~CRYPTO_SHA256"
-       local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
-       local WARNING_CRYPTO_SHA256="CONFIG_CRYPTO_SHA256:\tis not set (required for cryptsetup)\n"
-       local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
-       local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
-       check_extra_config
-}
-
-src_prepare() {
-       sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test || die
-       #epatch "${PATCHES[@]}"
-       epatch_user && eautoreconf
-
-       if use python ; then
-               cd python
-               cp "${FILESDIR}"/setup-1.7.0.py setup.py || die
-               distutils-r1_src_prepare
-       fi
-}
-
-src_configure() {
-       if use kernel ; then
-               ewarn "Note that kernel backend is very slow for this type of operation"
-               ewarn "and is provided mainly for embedded systems wanting to avoid"
-               ewarn "userspace crypto libraries."
-       fi
-
-       # We disable autotool python integration so we can use eclasses
-       # for proper integration with multiple python versions.
-       econf \
-               --sbindir=/sbin \
-               --enable-shared \
-               --disable-python \
-               $(use_enable static static-cryptsetup) \
-               $(use_enable static-libs static) \
-               $(use_enable nls) \
-               $(use_enable pwquality) \
-               $(use_enable reencrypt cryptsetup-reencrypt) \
-               $(use_enable udev) \
-               $(use_enable !urandom dev-random) \
-               --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
-
-       use python && cd python && distutils-r1_src_configure
-}
-
-src_compile() {
-       default
-       use python && cd python && distutils-r1_src_compile
-}
-
-src_test() {
-       if [[ ! -e /dev/mapper/control ]] ; then
-               ewarn "No /dev/mapper/control found -- skipping tests"
-               return 0
-       fi
-       local p
-       for p in /dev/mapper /dev/loop* ; do
-               addwrite ${p}
-       done
-       default
-}
-
-src_install() {
-       default
-       if use static ; then
-               mv "${ED}"/sbin/cryptsetup{.static,} || die
-               mv "${ED}"/sbin/veritysetup{.static,} || die
-               use reencrypt && { mv "${ED}"/sbin/cryptsetup-reencrypt{.static,} || die ; }
-       fi
-       prune_libtool_files --modules
-
-       newconfd "${FILESDIR}"/1.6.7-dmcrypt.confd dmcrypt
-       newinitd "${FILESDIR}"/1.6.7-dmcrypt.rc dmcrypt
-
-       use python && cd python && distutils-r1_src_install
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-2.2.2.ebuild b/sys-fs/cryptsetup/cryptsetup-2.2.2.ebuild
deleted file mode 100644 (file)
index e48c4ff..0000000
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools linux-info libtool
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="https://gitlab.com/cryptsetup/cryptsetup/blob/master/README.md"
-SRC_URI="https://www.kernel.org/pub/linux/utils/${PN}/v$(ver_cut 1-2)/${P/_/-}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0/12" # libcryptsetup.so version
-[[ ${PV} != *_rc* ]] && \
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
-# we don't support nss since it doesn't allow cryptsetup to be built statically
-# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
-REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
-       libressl? ( openssl )
-       static? ( !gcrypt )" #496612
-
-LIB_DEPEND="
-       dev-libs/json-c:=[static-libs(+)]
-       dev-libs/libgpg-error[static-libs(+)]
-       dev-libs/popt[static-libs(+)]
-       >=sys-apps/util-linux-2.31-r1[static-libs(+)]
-       argon2? ( app-crypt/argon2:=[static-libs(+)] )
-       gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
-       nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
-       openssl? (
-               !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
-               libressl? ( dev-libs/libressl:0=[static-libs(+)] )
-       )
-       pwquality? ( dev-libs/libpwquality[static-libs(+)] )
-       sys-fs/lvm2[static-libs(+)]
-       udev? ( virtual/libudev[static-libs(-)] )"
-# We have to always depend on ${LIB_DEPEND} rather than put behind
-# !static? () because we provide a shared library which links against
-# these other packages. #414665
-RDEPEND="static-libs? ( ${LIB_DEPEND} )
-       ${LIB_DEPEND//\[static-libs\([+-]\)\]}"
-DEPEND="${RDEPEND}
-       static? ( ${LIB_DEPEND} )"
-BDEPEND="
-       virtual/pkgconfig
-"
-
-S="${WORKDIR}/${P/_/-}"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.0.4-fix-static-pwquality-build.patch )
-
-pkg_pretend() {
-       if ! use luks1_default ; then
-               ewarn "WARNING! WARNING! WARNING!"
-               ewarn "You have chosen LUKS2 as your default format."
-               ewarn "This can break LUKS1 backwards compatibility."
-               ewarn "Enable \"luks1_default\" USE flag if you need backwards compatibility."
-       fi
-}
-
-pkg_setup() {
-       local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC ~CRYPTO_SHA256"
-       local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
-       local WARNING_CRYPTO_SHA256="CONFIG_CRYPTO_SHA256:\tis not set (required for cryptsetup)\n"
-       local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
-       local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
-       check_extra_config
-}
-
-src_prepare() {
-       sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test || die
-       default
-       eautoreconf
-}
-
-src_configure() {
-       if use kernel ; then
-               ewarn "Note that kernel backend is very slow for this type of operation"
-               ewarn "and is provided mainly for embedded systems wanting to avoid"
-               ewarn "userspace crypto libraries."
-       fi
-
-       local myeconfargs=(
-               --disable-internal-argon2
-               --enable-shared
-               --sbindir=/sbin
-               # for later use
-               --with-default-luks-format=LUKS$(usex luks1_default 1 2)
-               --with-tmpfilesdir="${EPREFIX}/usr/lib/tmpfiles.d"
-               --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
-               $(use_enable argon2 libargon2)
-               $(use_enable nls)
-               $(use_enable pwquality)
-               $(use_enable reencrypt cryptsetup-reencrypt)
-               $(use_enable static static-cryptsetup)
-               $(use_enable static-libs static)
-               $(use_enable udev)
-               $(use_enable !urandom dev-random)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_test() {
-       if [[ ! -e /dev/mapper/control ]] ; then
-               ewarn "No /dev/mapper/control found -- skipping tests"
-               return 0
-       fi
-
-       local p
-       for p in /dev/mapper /dev/loop* ; do
-               addwrite ${p}
-       done
-
-       default
-}
-
-src_install() {
-       default
-
-       if use static ; then
-               mv "${ED}"/sbin/cryptsetup{.static,} || die
-               mv "${ED}"/sbin/veritysetup{.static,} || die
-               if use reencrypt ; then
-                       mv "${ED}"/sbin/cryptsetup-reencrypt{.static,} || die
-               fi
-       fi
-       find "${ED}" -type f -name "*.la" -delete || die
-
-       dodoc docs/v*ReleaseNotes
-
-       newconfd "${FILESDIR}"/1.6.7-dmcrypt.confd dmcrypt
-       newinitd "${FILESDIR}"/1.6.7-dmcrypt.rc dmcrypt
-}
diff --git a/sys-fs/cryptsetup/files/setup-1.7.0.py b/sys-fs/cryptsetup/files/setup-1.7.0.py
deleted file mode 100644 (file)
index 0da063c..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-import os
-from distutils.core import setup, Extension
-
-top_srcdir = os.path.dirname(os.path.dirname(os.path.realpath(__file__)))
-
-def get_ver():
-    with open(os.path.join(top_srcdir, 'configure')) as f:
-        for line in f:
-            if line.startswith('PACKAGE_VERSION='):
-                return line.split('=')[1].replace("'", '').strip()
-
-module = Extension('pycryptsetup',
-                   include_dirs=[os.path.join(top_srcdir, 'lib')],
-                   extra_compile_args=['-include', os.path.join(top_srcdir, 'config.h')],
-                   library_dirs=[os.path.join(top_srcdir, 'lib', '.libs')],
-                   libraries=['cryptsetup'],
-                   sources=['pycryptsetup.c'])
-
-setup(name='pycryptsetup',
-      version=get_ver(),
-      ext_modules=[module])