app-emulation/docker-compose: add version 1.4.0
authorAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 20:51:32 +0000 (15:51 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 20:51:32 +0000 (15:51 -0500)
Package-Manager: portage-2.2.20.1

app-emulation/docker-compose/Manifest
app-emulation/docker-compose/docker-compose-1.4.0.ebuild [new file with mode: 0644]
app-emulation/docker-compose/files/expand-request-versions.patch [new file with mode: 0644]

index fe0f61817bdec56820921662fc26498369e8b42e..a2bae4afaf3cac1fe938456c7733344d3197557d 100644 (file)
@@ -1 +1,2 @@
 DIST docker-compose-1.2.0.tar.gz 57150 SHA256 46ef3c5cb7dd79fa7fd1d5fc5ec5be6a5c634192bc09c604c0ea75adb89cb652 SHA512 d13f6d6d22979dbc4554c003e611097627e2273f06dd13a1c666c1ba138288597ebef08f1beaf6d342721391cb49ad5ce9ae2ff03367a041fc0c53fbb62c9ac4 WHIRLPOOL c7bb3e14a4c2788eb49241ce02dcaed5e49fe60652ca1a51d13e1712f946046415f5397d5bf892b5e0451059a4aee1b156ee7bdfdf64a22d000caae7b17254c0
+DIST docker-compose-1.4.0.tar.gz 79532 SHA256 2748cc8dd0829b44f0f686e36683cab58e1a4bc869442a04508504d2f62d0337 SHA512 470442aa78ddb24e8b9287953031e17a96a89780edd3a85955c923ffe00f4bfe655412dc15422437121593d7e2899f0847813d3716fc9ed576f93e6455cb868b WHIRLPOOL 9dc6731dad3df6422ec1e1b66049c8e9f04068b2fc2c8180da44220c1fbedc4919dfe17475cd539c3f33a079f3d04f875baaf769a7bc0875de48cf622670dc4b
diff --git a/app-emulation/docker-compose/docker-compose-1.4.0.ebuild b/app-emulation/docker-compose/docker-compose-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..9727762
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker-compose/docker-compose-1.2.0-r1.ebuild,v 1.1 2015/05/02 15:59:55 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/dockerpty-0.3.4[${PYTHON_USEDEP}]
+       <dev-python/dockerpty-0.4[${PYTHON_USEDEP}]
+       >=dev-python/docker-py-1.3.1[${PYTHON_USEDEP}]
+       <dev-python/docker-py-1.4[${PYTHON_USEDEP}]
+       >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+       <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+       <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+       >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+       <dev-python/six-2[${PYTHON_USEDEP}]
+       >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+       <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+       <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       test? (
+               ${CDEPEND}
+               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+python_prepare_all() {
+       local PATCHES=(
+               "${FILESDIR}"/expand-request-versions.patch
+       )
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+       insinto /usr/share/zsh/site-functions
+       doins contrib/completion/zsh/*
+
+       distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/expand-request-versions.patch b/app-emulation/docker-compose/files/expand-request-versions.patch
new file mode 100644 (file)
index 0000000..a1c9bb5
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 9bca475..5ea5e73 100644
+--- a/setup.py
++++ b/setup.py
+@@ -27,7 +27,7 @@ def find_version(*file_paths):
+ install_requires = [
+     'docopt >= 0.6.1, < 0.7',
+     'PyYAML >= 3.10, < 4',
+-    'requests >= 2.6.1, < 2.7',
++    'requests >= 2.6.1',
+     'texttable >= 0.8.1, < 0.9',
+     'websocket-client >= 0.32.0, < 1.0',
+     'docker-py >= 1.3.1, < 1.4',