dev-haskell/shakespeare: drop underscores from IUSEs, bug #695042
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 27 Sep 2019 06:49:51 +0000 (07:49 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 27 Sep 2019 06:49:51 +0000 (07:49 +0100)
Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/695042
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/shakespeare/metadata.xml
dev-haskell/shakespeare/shakespeare-1.2.1.1.ebuild
dev-haskell/shakespeare/shakespeare-2.0.12.1.ebuild
dev-haskell/shakespeare/shakespeare-2.0.7.ebuild

index 4628e04a14a64a3aae2ccea4127b7266395a0ed2..51b9253245db86b91f586a86b2853d6e4f00978d 100644 (file)
@@ -14,8 +14,8 @@
                Please see the documentation at &lt;http://docs.yesodweb.com/book/hamlet/&gt; for more details.
        </longdescription>
        <use>
-               <flag name="test_export">Test export.</flag>
-               <flag name="test_coffee">Render tests through coffeescript render function.</flag>
-               <flag name="test_roy">Render tests through roy render function.</flag>
+               <flag name="test-export">Test export.</flag>
+               <flag name="test-coffee">Render tests through coffeescript render function.</flag>
+               <flag name="test-roy">Render tests through roy render function.</flag>
        </use>
 </pkgmetadata>
index 4d81aa004c1adae1c68ee908a8575f2a869c027a..88a5c85de2f7dc52bdc0e2caf10e4c40e9e78dc5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="test_export"
+IUSE="test-export"
 
 RDEPEND=">=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-4:=[profile?]
        >=dev-haskell/system-fileio-0.3:=[profile?]
@@ -30,5 +30,5 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag test_export test_export)
+               $(cabal_flag test-export test_export)
 }
index 139c98fd3d3bde27228cc31a46039f288fbc110c..e77dec6c95a19bfe10aa1a0405e74ef8a256e9d2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="test_coffee test_export test_roy"
+IUSE="test-coffee test-export test-roy"
 
 RDEPEND="dev-haskell/aeson:=[profile?]
        dev-haskell/blaze-html:=[profile?]
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag test_coffee test_coffee) \
-               $(cabal_flag test_export test_export) \
-               $(cabal_flag test_roy test_roy)
+               $(cabal_flag test-coffee test_coffee) \
+               $(cabal_flag test-export test_export) \
+               $(cabal_flag test-roy test_roy)
 }
index d4eb111b7497b8f3da18d76fc9b3dccfc12ce1fe..441a3a041a9c7da40e394f674646bf761f75a6aa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="test_coffee test_export test_roy"
+IUSE="test-coffee test-export test-roy"
 
 RDEPEND="dev-haskell/aeson:=[profile?]
        dev-haskell/blaze-html:=[profile?]
@@ -37,7 +37,7 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag test_coffee test_coffee) \
-               $(cabal_flag test_export test_export) \
-               $(cabal_flag test_roy test_roy)
+               $(cabal_flag test-coffee test_coffee) \
+               $(cabal_flag test-export test_export) \
+               $(cabal_flag test-roy test_roy)
 }