sci-physics/vgm: Version bump to 4.5.
authorOliver Freyermuth <o.freyermuth@googlemail.com>
Mon, 15 Jul 2019 17:50:19 +0000 (19:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 18 Jul 2019 18:00:21 +0000 (20:00 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
Closes: https://github.com/gentoo/gentoo/pull/12449
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-physics/vgm/Manifest
sci-physics/vgm/vgm-4.5.ebuild [new file with mode: 0644]

index ea44ee2059a8abc6b27fdd185ec73882f9ef1a8f..0ff4444fb7a691f33f945634fef0aee35b0e57da 100644 (file)
@@ -1 +1,2 @@
 DIST vgm.4.4.tar.gz 3064087 BLAKE2B 845d04fa3ebaaa07f90ef7f216cac10e5ca4129ebbd6161e3fecce39663379b2575026186fe2b88ae8bf08f71bed6d8afcbbd5d7aa9922d37b3f9ed900d35a33 SHA512 500ae0e2ac66b580bbc26b6cd1a8bd6d6e3127c99e6fe6babe5825406e576d72da5cd76d22d0d1b82d7df9eb74ddddf084ee9a96b544c97af5b12cbf948d3406
+DIST vgm.4.5.tar.gz 9602541 BLAKE2B 183c8ed91546e5421c4f1a873a48285e9d2ab6bf4bb6a7bb7b46ab2c3c80a5dfc50cd5f97890c3994ada67014067349726e9f4d65cda1e1e4f1ae9484a4249ef SHA512 a873e24ed2c6cfc09d1828b60af9059a0bee341410e5cb77c9312aa72f1650a913779a0ff929d98910f01fcc5a3e6a04b352dd1a780a8bf60b1fa925b1985491
diff --git a/sci-physics/vgm/vgm-4.5.ebuild b/sci-physics/vgm/vgm-4.5.ebuild
new file mode 100644 (file)
index 0000000..7053d1d
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+else
+       SRC_URI="http://ivana.home.cern.ch/ivana/${PN}.${PV}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+       S="${WORKDIR}/${PN}"
+fi
+
+DESCRIPTION="Virtual Geometry Model for High Energy Physics Experiments"
+HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc examples +geant4 +root test"
+
+# sci-physics/root[c++11] required to match sci-physics/geant
+RDEPEND="
+       sci-physics/clhep:=
+       root? ( sci-physics/root:=[c++11] )
+       geant4? ( >=sci-physics/geant-4.10.03 )"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen[dot] )
+       test? ( sci-physics/geant-vmc[g4root] )"
+RESTRICT="
+       !geant4? ( test )
+       !root? ( test )
+       !test? ( test )"
+
+DOCS=(
+       doc/README
+       doc/todo.txt
+       doc/VGMhistory.txt
+       doc/VGM.html
+       doc/VGMversions.html
+)
+PATCHES=(
+       "${FILESDIR}"/"${PN}-fix-FindCLHEP.patch"
+)
+
+src_configure() {
+       local mycmakeargs=(
+               -DCLHEP_DIR="${EROOT}usr"
+               -DWITH_EXAMPLES="$(usex examples)"
+               -DINSTALL_EXAMPLES="$(usex examples)"
+               -DWITH_GEANT4="$(usex geant4)"
+               -DWITH_ROOT="$(usex root)"
+               -DWITH_TEST="$(usex test)"
+       )
+       if use test && use root && use geant4; then
+               mycmakeargs+=( -DWITH_G4ROOT=yes )
+       else
+               mycmakeargs+=( -DWITH_G4ROOT=no )
+       fi
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+       if use doc; then
+               cd packages
+               doxygen || die
+       fi
+}
+
+src_test() {
+       cd "${BUILD_DIR}"/test || die
+       ./test_suite.sh || die
+}
+
+src_install() {
+       cmake-utils_src_install
+       use doc && local HTML_DOCS=( doc/html/. )
+       einstalldocs
+}