dev-libs/libixion: Pin dev-util/mdds to (API-)slot; bump subslot
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 11:56:41 +0000 (13:56 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 13:48:38 +0000 (15:48 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libixion/libixion-0.15.0.ebuild
dev-libs/libixion/libixion-9999.ebuild

index 58f699f6b1955e197e56489aa311f78b7705b64d..2387edbadd60c5c7545c6171ac5ea2f01fb8806a 100644 (file)
@@ -25,7 +25,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
 RDEPEND="
        dev-libs/boost:=
-       >=dev-util/mdds-1.5.0:1=
+       dev-util/mdds:1/1.5
        python? ( ${PYTHON_DEPS} )
 "
 DEPEND="${RDEPEND}
index 741d54be08e41ca6404845399e63261edf47c8d0..28084226f1e7c19161e4170165061046ee77d805 100644 (file)
@@ -10,22 +10,24 @@ DESCRIPTION="General purpose formula parser & interpreter"
 HOMEPAGE="https://gitlab.com/ixion/ixion"
 
 if [[ ${PV} == *9999 ]]; then
+       MDDS_SLOT="1/9999"
        EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
        inherit git-r3 autotools
 else
+       MDDS_SLOT="1/1.5"
        SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
        KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
 fi
 
 LICENSE="MIT"
-SLOT="0/0.15" # based on SONAME of libixion.so
+SLOT="0/0.16" # based on SONAME of libixion.so
 IUSE="debug python static-libs +threads"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
 RDEPEND="
        dev-libs/boost:=
-       >=dev-util/mdds-1.5.0:1=
+       dev-util/mdds:${MDDS_SLOT}
        python? ( ${PYTHON_DEPS} )
 "
 DEPEND="${RDEPEND}