media-libs/libclastfm: EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 02:06:06 +0000 (03:06 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 02:32:35 +0000 (03:32 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/libclastfm/libclastfm-0.5.ebuild

index 78d0075ed22f92b609e1e03c5f58ec372b36dcca..ec203eb68942efb9961632a3a34fdf95650845d5 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 DESCRIPTION="C API library to the last.fm web service (unofficial)"
 HOMEPAGE="http://liblastfm.sourceforge.net/"
@@ -12,11 +12,11 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE="static-libs"
 
-RDEPEND="net-misc/curl"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
 
-DOCS="AUTHORS README"
+DOCS=( AUTHORS README )
 
 src_configure() {
        econf $(use_enable static-libs static)
@@ -24,5 +24,5 @@ src_configure() {
 
 src_install() {
        default
-       rm -f "${ED}"/usr/lib*/*.la
+       find "${D}" -name '*.la' -type f -delete || die
 }