media-libs/libplacebo: update to 1.18.0.
authorMihai Moldovan <ionic@ionic.de>
Thu, 9 May 2019 06:30:01 +0000 (08:30 +0200)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 9 May 2019 19:16:00 +0000 (12:16 -0700)
Additionally, bump up to EAPI 7. No actual packaging changes needed.

Also, modernize ebuild a bit. The meson eclass now has features like
meson_{feature,use}, which we can use to shorten out a lot of feature
tests.

Add support for the optional testing framework.

Do not call ninja directly, but rather use the
meson_src_{build,test,install} functions.

Package-Manager: Portage-2.3.66, Repoman-2.3.12

Signed-off-by: Mihai Moldovan <ionic@ionic.de>
Closes: https://github.com/gentoo/gentoo/pull/11938
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
media-libs/libplacebo/Manifest
media-libs/libplacebo/libplacebo-1.18.0.ebuild [new file with mode: 0644]

index d69d907033fc8527f9d4122047b92e38b10ed580..d1476f6691565d3a3fb4911de2e5e41116748031 100644 (file)
@@ -1 +1,2 @@
+DIST libplacebo-v1.18.0.tar.gz 322963 BLAKE2B 640accaa64b1a5abdcc60f89c1b80ccc880ed060799a48cb9d41c7b891648913b05d06c62fa6dd21ccce07ac61b7c89e1702ac26013c596dc4a4d71c7b10721f SHA512 a2ca4a8b2bf9e5242c39c704e579575ccbfd0a7dadc4f73fe1994abb6e3f132d19f6d95415704a62e285e3f94e7b0ab8aeed14b4fce466df1ba34952f7127686
 DIST libplacebo-v1.7.0.tar.gz 312154 BLAKE2B 46a807e323cce5da6362828d931daeca3eaff8475a7318dfc756c097e2edc98f064a90b36e0f6d882f95f6bb077e72127fb6f8d7643dd992c7432a13b6fdbe64 SHA512 337662e538b1d6b3d063ec18db2627619e1bd72cff6017ac19027527b07a74b0f196a428b572c9f4e3c3856c32a123b70049d7938458fb4301fdd319d756ab27
diff --git a/media-libs/libplacebo/libplacebo-1.18.0.ebuild b/media-libs/libplacebo/libplacebo-1.18.0.ebuild
new file mode 100644 (file)
index 0000000..5ab0605
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://code.videolan.org/videolan/libplacebo.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://code.videolan.org/videolan/libplacebo/-/archive/v${PV}/libplacebo-v${PV}.tar.gz"
+       S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+inherit meson multilib-minimal
+
+DESCRIPTION="Reusable library for GPU-accelerated image processing primitives"
+HOMEPAGE="https://github.com/haasn/libplacebo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="glslang lcms +shaderc test +vulkan"
+REQUIRED_USE="vulkan? ( || ( glslang shaderc ) )"
+
+RDEPEND="glslang? ( <dev-util/glslang-7.10[${MULTILIB_USEDEP}] )
+       lcms? ( media-libs/lcms:2[${MULTILIB_USEDEP}] )
+       shaderc? ( >=media-libs/shaderc-2017.2[${MULTILIB_USEDEP}] )
+       vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_feature glslang)
+               $(meson_feature lcms)
+               $(meson_feature shaderc)
+               $(meson_use test tests)
+               $(meson_feature vulkan)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}