dev-tex/dvi2gr: EAPI7, improve ebuild.
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 5 Aug 2018 16:05:40 +0000 (18:05 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 20 Aug 2018 15:00:33 +0000 (17:00 +0200)
Closes: https://bugs.gentoo.org/663808
Closes: https://github.com/gentoo/gentoo/pull/9461

dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild [new file with mode: 0644]

diff --git a/dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild b/dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild
new file mode 100644 (file)
index 0000000..0de71ab
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DVI to Grace translator"
+HOMEPAGE="http://plasma-gate.weizmann.ac.il/Grace/"
+SRC_URI="ftp://plasma-gate.weizmann.ac.il/pub/grace/src/devel/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="media-libs/t1lib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       tc-export CC
+       default
+       # respect flags
+       sed -i \
+               -e '/^LDFLAGS/d' -e '/^CFLAGS/d' -e '/^CC/d' \
+               Makefile || die
+       sed -i -e 's/DVI2GR=\.\/dvi2gr/DVI2GR=$(which dvi2gr)/g' runtest.sh || die
+}
+
+src_install() {
+       dobin ${PN}
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins *.ti runtest.sh
+       fi
+
+       insinto /usr/share/${PN}
+       doins -r fonts
+}
+
+pkg_postinst() {
+       einfo "Don't forget install the TeX-Fonts in Grace"
+       einfo "  /usr/share/${PN}/fonts/FontDataBase"
+}