dev-python/clang-python: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:35 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:43 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/clang-python/clang-python-10.0.0.9999.ebuild
dev-python/clang-python/clang-python-9.0.1.9999.ebuild

index 5a65d445f01fc3d24301b4c61eb20d4939befbc2..24e14b038ecf9336ba6a3c714a3851f001355b74 100644 (file)
@@ -9,10 +9,8 @@ inherit git-r3 python-r1
 DESCRIPTION="Python bindings for sys-devel/clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-S=${WORKDIR}/${P}/bindings/python
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
-       https://github.com/llvm-mirror/clang.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/clang/bindings/python
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -32,7 +30,7 @@ DEPEND="${RDEPEND}"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' bindings/python
+       git-r3_checkout '' '' '' clang/bindings/python
 }
 
 python_test() {
index d1c47b42ebfc99e4c3d2749da0913b26e56c467f..45d2a38e5e5906bf86187d1c2fe8cf020e2c36a5 100644 (file)
@@ -9,11 +9,9 @@ inherit git-r3 python-r1
 DESCRIPTION="Python bindings for sys-devel/clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-S=${WORKDIR}/${P}/bindings/python
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
-       https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/clang/bindings/python
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -33,7 +31,7 @@ DEPEND="${RDEPEND}"
 
 src_unpack() {
        git-r3_fetch
-       git-r3_checkout '' '' '' bindings/python
+       git-r3_checkout '' '' '' clang/bindings/python
 }
 
 python_test() {