dev-python/python-gnutls: initial import of version 2.0.1
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 11:06:54 +0000 (13:06 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:15 +0000 (19:40 +0200)
dev-python/python-gnutls/Manifest [new file with mode: 0644]
dev-python/python-gnutls/metadata.xml [new file with mode: 0644]
dev-python/python-gnutls/python-gnutls-2.0.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-gnutls/Manifest b/dev-python/python-gnutls/Manifest
new file mode 100644 (file)
index 0000000..98c57a6
--- /dev/null
@@ -0,0 +1 @@
+DIST python-gnutls-2.0.1.tar.gz 42560 SHA256 d8fb368c6a4dd58bc6cd5e61d4a12d119c4506fd344a371b3429b3ac2623b9ac SHA512 6dca8ba9e98e76add30502825f5711e3bc6f22b2a1e28416a3c1acacec41eb45e4e2f63c0185fa10f8e518df41f1093ba33ab33a5f69dd25300e17db1022b3df WHIRLPOOL 6094b85c04f3ea75d76c4e51b90a81f056ecd8e495d1670f2e5bb728b4047a6ef1fdedeeb2cf3f3be856d77f8f2306f5e2b257c233029597741028d162bb5a02
diff --git a/dev-python/python-gnutls/metadata.xml b/dev-python/python-gnutls/metadata.xml
new file mode 100644 (file)
index 0000000..a1b5a57
--- /dev/null
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               This package provides a high level object oriented wrapper around
+               libgnutls, as well as low level bindings to the GNUTLS types and
+               functions via ctypes. The high level wrapper hides the details of
+               accessing the GNUTLS library via ctypes behind a set of classes that
+               encapsulate GNUTLS sessions, certificates and credentials and expose
+               them to python applications using a simple API.
+
+               The package also includes a Twisted interface that has seamless
+               intergration with Twisted, providing connectTLS and listenTLS methods
+               on the Twisted reactor once imported (the methods are automatically
+               attached to the reactor by simply importing the GNUTLS Twisted
+               interface module).
+
+               The high level wrapper is written using the GNUTLS library bindings
+               that are made available via ctypes. This makes the wrapper very
+               powerful and flexible as it has direct access to all the GNUTLS
+               internals and is also very easy to extend without any need to write
+               C code or recompile anything.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">python-gnutls</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gnutls/python-gnutls-2.0.1.ebuild b/dev-python/python-gnutls/python-gnutls-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..8179f60
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="High level object oriented wrapper around libgnutls"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/gnutls"