sci-biology/njplot: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 21:32:53 +0000 (22:32 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 21:39:15 +0000 (22:39 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/njplot/njplot-2.3-r2.ebuild [new file with mode: 0644]

diff --git a/sci-biology/njplot/njplot-2.3-r2.ebuild b/sci-biology/njplot/njplot-2.3-r2.ebuild
new file mode 100644 (file)
index 0000000..ac85784
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/njplot-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       sci-biology/ncbi-tools[X,static-libs]
+       x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-format-security.patch
+       "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_prepare() {
+       default
+       sed -i -e "s:njplot.help:${EPREFIX}/usr/share/doc/${PF}/njplot.help:" njplot-vib.c || die
+
+       tc-export CC
+}
+
+src_install() {
+       dobin newicktops newicktotxt njplot unrooted
+       doman *.1
+       dodoc README njplot.help
+}