app-arch/bzip2: fix an error reported by ubsan
authorManoj Gupta <manojgupta@google.com>
Fri, 24 Aug 2018 17:43:58 +0000 (19:43 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 24 Aug 2018 17:47:29 +0000 (19:47 +0200)
Use unsigned 1 for shifting instead of signed 1.

Fix an issue with shift caught by undefined behavior
sanitizer in clang.
bzip2-1.0.6/blocksort.c:255:7
runtime error: left shift of 1 by 31 places cannot be represented
in type 'int'.

Closes: https://github.com/gentoo/gentoo/pull/9688
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-arch/bzip2/bzip2-1.0.6-r10.ebuild [moved from app-arch/bzip2/bzip2-1.0.6-r9.ebuild with 98% similarity]
app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch [new file with mode: 0644]

similarity index 98%
rename from app-arch/bzip2/bzip2-1.0.6-r9.ebuild
rename to app-arch/bzip2/bzip2-1.0.6-r10.ebuild
index b2bae1f09890db1e996e9930ed8b2a14bd744256..5fb91d277fa89e03b7ed3ec795de6cd82b21fbf1 100644 (file)
@@ -27,6 +27,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
        "${FILESDIR}"/${PN}-1.0.6-out-of-tree-build.patch
        "${FILESDIR}"/${PN}-1.0.6-CVE-2016-3189.patch #620466
+       "${FILESDIR}"/${PN}-1.0.6-ubsan-error.patch
 )
 
 DOCS=( CHANGES README{,.COMPILATION.PROBLEMS,.XML.STUFF} manual.pdf )
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch b/app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch
new file mode 100644 (file)
index 0000000..84b8111
--- /dev/null
@@ -0,0 +1,24 @@
+Author: Manoj Gupta <manojgupta@google.com>
+
+Use unsigned 1 for shifting instead of signed 1.
+
+This fixed an issue with shift caught by undefined behavior
+sanitizer in clang.
+bzip2-1.0.6/blocksort.c:255:7
+runtime error: left shift of 1 by 31 places cannot be represented in type 'int'
+
+--- a/blocksort.c
++++ b/blocksort.c
+@@ -202,9 +202,9 @@ void fallbackQSort3 ( UInt32* fmap,
+       bhtab [ 0 .. 2+(nblock/32) ] destroyed
+ */
+-#define       SET_BH(zz)  bhtab[(zz) >> 5] |= (1 << ((zz) & 31))
+-#define     CLEAR_BH(zz)  bhtab[(zz) >> 5] &= ~(1 << ((zz) & 31))
+-#define     ISSET_BH(zz)  (bhtab[(zz) >> 5] & (1 << ((zz) & 31)))
++#define       SET_BH(zz)  bhtab[(zz) >> 5] |= (1u << ((zz) & 31))
++#define     CLEAR_BH(zz)  bhtab[(zz) >> 5] &= ~(1u << ((zz) & 31))
++#define     ISSET_BH(zz)  (bhtab[(zz) >> 5] & (1u << ((zz) & 31)))
+ #define      WORD_BH(zz)  bhtab[(zz) >> 5]
+ #define UNALIGNED_BH(zz)  ((zz) & 0x01f)