dev-haskell/hit: new package, a depend of dev-haskell/stack
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 28 May 2017 12:49:10 +0000 (13:49 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 28 May 2017 17:52:57 +0000 (18:52 +0100)
Git operations in haskell

Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-haskell/hit/Manifest [new file with mode: 0644]
dev-haskell/hit/hit-0.6.3.ebuild [new file with mode: 0644]
dev-haskell/hit/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/hit/Manifest b/dev-haskell/hit/Manifest
new file mode 100644 (file)
index 0000000..be9a68e
--- /dev/null
@@ -0,0 +1 @@
+DIST hit-0.6.3.tar.gz 38690 SHA256 db86b3712029a4e40d1306dd6cc9ca2c9f4c77fe65a2b74106f1cbd2de26e471 SHA512 82ccfeb77a439caa1792f1ae29535636764be9e6e94f75973f37a86db6627a492e57da835954384ef8468799de9f0897e20905f65dad256fe3547a4248d5fffc WHIRLPOOL e90e0d842666b027be5c3996a233e66385c9cb62d694a8dd923ca20cfadeedabc892dc25c5a6367310cf9d3892e731563234fe49330e48cd1a46346095388c0c
diff --git a/dev-haskell/hit/hit-0.6.3.ebuild b/dev-haskell/hit/hit-0.6.3.ebuild
new file mode 100644 (file)
index 0000000..4661017
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Git operations in haskell"
+HOMEPAGE="https://github.com/vincenthz/hit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug executable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.1:=[profile?]
+       dev-haskell/byteable:=[profile?]
+       dev-haskell/cryptohash:=[profile?]
+       >=dev-haskell/hourglass-0.2:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       >=dev-haskell/parsec-3:=[profile?]
+       dev-haskell/patience:=[profile?]
+       dev-haskell/random:=[profile?]
+       dev-haskell/system-fileio:=[profile?]
+       dev-haskell/system-filepath:=[profile?]
+       dev-haskell/unix-compat:=[profile?]
+       dev-haskell/utf8-string:=[profile?]
+       dev-haskell/vector:=[profile?]
+       dev-haskell/zlib:=[profile?]
+       >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+       executable? ( >=dev-haskell/hashable-1.2:=[profile?]
+                       dev-haskell/hashtables:=[profile?] )
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8
+       test? ( >=dev-haskell/bytedump-1.0
+               dev-haskell/tasty
+               dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               $(cabal_flag debug debug) \
+               $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/hit/metadata.xml b/dev-haskell/hit/metadata.xml
new file mode 100644 (file)
index 0000000..3f0d2b7
--- /dev/null
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+           <email>haskell@gentoo.org</email>
+           <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               
+               An haskell implementation of git storage operations, allowing users
+               to manipulate git repositories (read and write).
+               
+               This implementation is fully interoperable with the main C implementation.
+               
+               This is stricly only manipulating the git store (what's inside the .git directory),
+               and doesn't do anything with the index or your working directory files.
+               
+       </longdescription>
+       <use>
+           <flag name="executable">Build the executable</flag>
+       </use>
+</pkgmetadata>