www-servers/monkeyd: fix build on uClibc
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 00:45:05 +0000 (20:45 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 01:02:59 +0000 (21:02 -0400)
Package-Manager: portage-2.2.20.1

www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild

index e265962791f53d976b04b1ea05d1fc9867464d83..d07b3b808783e5cc250bd53307435c120d7ed722 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI="5"
 
-inherit toolchain-funcs depend.php multilib
+inherit flag-o-matic toolchain-funcs multilib
 
 MY_P="${PN/d}-${PV}"
 DESCRIPTION="A small, fast, and scalable web server"
@@ -86,6 +86,13 @@ src_configure() {
                myconf+=" --static-plugins=${enable_plugins%,}"
        fi
 
+       # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
+       # but shouldn't because it is POSIX.  This needs to be fixed
+       # in uClibc.  Also, we really should us append-cppflags but
+       # monkey's build system doesn't respect CPPFLAGS.  This needs
+       # to be fixed in monkey.
+       use elibc_uclibc && append-cflags -D_GNU_SOURCE
+
        # Non-autotools configure
        ./configure \
                --pthread-tls \