old
authorMike Frysinger <vapier@gentoo.org>
Thu, 18 Jan 2007 05:12:54 +0000 (05:12 +0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 18 Jan 2007 05:12:54 +0000 (05:12 +0000)
sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208 [deleted file]
sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205 [deleted file]
sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061216 [deleted file]
sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild [deleted file]
sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild [deleted file]
sys-devel/gcc/gcc-4.3.0_alpha20061216.ebuild [deleted file]

diff --git a/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208 b/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061208
deleted file mode 100644 (file)
index 6d60cf2..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 262a3a0a31e2c172fbc22afd09dcaf30 gcc-4.1-20061208.tar.bz2 37282125
-RMD160 d5ee2f8728031380c4ae4967022c7861b6a4b99b gcc-4.1-20061208.tar.bz2 37282125
-SHA256 73880b99e3c245d7953fd72988397c2c6a53be16ef798a75bd62c7ded818bee5 gcc-4.1-20061208.tar.bz2 37282125
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061205
deleted file mode 100644 (file)
index 17417f9..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 048a21fc644ab9e9e7a21fc84f2c694d gcc-4.2-20061205.tar.bz2 40697459
-RMD160 a3b0a12abeaadd4dc9693a418a7f6630f1a53b46 gcc-4.2-20061205.tar.bz2 40697459
-SHA256 6dc3d92e4949c878b4e821612b558befb1d848367d525528551217c5b3eaccad gcc-4.2-20061205.tar.bz2 40697459
diff --git a/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061216 b/sys-devel/gcc/files/digest-gcc-4.3.0_alpha20061216
deleted file mode 100644 (file)
index 03f3be9..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1abc385274967289183bf311c712148a gcc-4.3-20061216.tar.bz2 41234730
-RMD160 7ba698f09add1256d91dc2d855cca4d8ccee9569 gcc-4.3-20061216.tar.bz2 41234730
-SHA256 d1e8873c6f73f263dba967a7fc6eb4daa342286c3108c80c64b21741f6e0d9a4 gcc-4.3-20061216.tar.bz2 41234730
diff --git a/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild b/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild
deleted file mode 100644 (file)
index 5e9ac64..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_alpha20061208.ebuild,v 1.1 2006/12/12 03:46:21 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       fortran? (
-               >=dev-libs/gmp-4.2.1
-               >=dev-libs/mpfr-2.2.0_p10
-       )
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild
deleted file mode 100644 (file)
index b51b109..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20061205.ebuild,v 1.1 2006/12/12 03:46:21 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       fortran? (
-               >=dev-libs/gmp-4.2.1
-               >=dev-libs/mpfr-2.2.0_p10
-       )
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}
diff --git a/sys-devel/gcc/gcc-4.3.0_alpha20061216.ebuild b/sys-devel/gcc/gcc-4.3.0_alpha20061216.ebuild
deleted file mode 100644 (file)
index 625a2be..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.0_alpha20061216.ebuild,v 1.1 2006/12/17 01:03:44 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       >=dev-libs/gmp-4.2.1
-       >=dev-libs/mpfr-2.2.0_p10
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}