x11-libs/cairo: tweak for binutils-2.34, bug #707960
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 4 Feb 2020 09:02:14 +0000 (09:02 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 4 Feb 2020 09:03:23 +0000 (09:03 +0000)
Reported-by: Hugo Ribeiro
Closes: https://bugs.gentoo.org/707960
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
x11-libs/cairo/cairo-1.16.0-r3.ebuild
x11-libs/cairo/cairo-9999.ebuild
x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch [new file with mode: 0644]

index 275c687dcf549fa6a3ad95042810f4c03cb28bcc..2d3601c7a3969522bc80186891950a027926b2d9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -67,6 +67,10 @@ PATCHES=(
 src_prepare() {
        default
 
+       if has_version ">=sys-libs/binutils-libs-2.34"; then
+               eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
+       fi
+
        # tests and perf tools require X, bug #483574
        if ! use X; then
                sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
index d5022d1759a3156fdf236c6aa5f2087d9fea6df1..29d74b12d970f2d5cc5b5e1e601d65a349f3ea00 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -65,6 +65,10 @@ PATCHES=(
 src_prepare() {
        default
 
+       if has_version ">=sys-libs/binutils-libs-2.34"; then
+               eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
+       fi
+
        # tests and perf tools require X, bug #483574
        if ! use X; then
                sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
diff --git a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
new file mode 100644 (file)
index 0000000..03daac0
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/util/cairo-trace/lookup-symbol.c
++++ b/util/cairo-trace/lookup-symbol.c
+@@ -145,14 +145,14 @@ find_address_in_section (bfd *abfd,
+     if (symbol->found)
+       return;
+-    if ((bfd_get_section_flags (symtab->bfd, section) & SEC_ALLOC) == 0)
++    if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
+       return;
+-    vma = bfd_get_section_vma (symtab->bfd, section);
++    vma = bfd_section_vma (section);
+     if (symbol->pc < vma)
+       return;
+-    size = bfd_section_size (symtab->bfd, section);
++    size = bfd_section_size (section);
+     if (symbol->pc >= vma + size)
+       return;