app-emacs/emacs-common-gentoo: Drop gnome2-utils.
authorUlrich Müller <ulm@gentoo.org>
Thu, 22 Aug 2019 12:34:36 +0000 (14:34 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 22 Aug 2019 12:44:18 +0000 (14:44 +0200)
gnome2_icon_savelist() and gnome2_icon_cache_update() are no longer
defined in EAPI 7. Use xdg_icon_cache_update as replacement.

Closes: https://bugs.gentoo.org/692520
Reported-by: Stephan Hartmann <stha09@googlemail.com>
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.6-r3.ebuild [moved from app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.6-r2.ebuild with 94% similarity]

similarity index 94%
rename from app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.6-r2.ebuild
rename to app-emacs/emacs-common-gentoo/emacs-common-gentoo-1.6-r3.ebuild
index 6cd58fb86134e2b033fc3ae3f726c4a69789f800..abe44b42f393ea8c38c4c601398d05bcd1179a25 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit elisp-common desktop xdg-utils gnome2-utils readme.gentoo-r1
+inherit elisp-common desktop xdg-utils readme.gentoo-r1
 
 DESCRIPTION="Common files needed by all GNU Emacs versions"
 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
@@ -48,8 +48,6 @@ src_install() {
                doicon -s scalable emacs23.svg
                newicon -s scalable emacs25.svg emacs.svg
                popd
-
-               gnome2_icon_savelist
        fi
 
        DOC_CONTENTS="All site initialisation for Gentoo-installed packages is
@@ -91,7 +89,7 @@ pkg_preinst() {
 pkg_postinst() {
        if use X; then
                xdg_desktop_database_update
-               gnome2_icon_cache_update
+               xdg_icon_cache_update
        fi
        readme.gentoo_print_elog
 }
@@ -99,6 +97,6 @@ pkg_postinst() {
 pkg_postrm() {
        if use X; then
                xdg_desktop_database_update
-               gnome2_icon_cache_update
+               xdg_icon_cache_update
        fi
 }