dev-python/backports-csv: Bump to 1.0.7, add tests
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 11:54:50 +0000 (13:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 11:55:23 +0000 (13:55 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/backports-csv/Manifest
dev-python/backports-csv/backports-csv-1.0.7.ebuild [new file with mode: 0644]

index 4f5218409826e08a47946ff94af5669893871147..bb613b51d9e1505790ead2d082a3f2564bee3713 100644 (file)
@@ -1 +1,2 @@
 DIST backports.csv-1.0.5.tar.gz 12050 BLAKE2B b6c5c4b846040167c081166fc4f0f0fb2df4f4d68e28a00e43762044f86e35c5e104a07028bcb7a7fa0f2d377b2da16d202308b4b905dad979118786c0ea0f7e SHA512 0b3885d818153bd50da2c7d931f64464cb344100622d9692925f9eaca056bf973f7d1d3546520e54e03472766c7d8b600c53e0674eb5958e768f713ec16a96a8
+DIST backports.csv-1.0.7.tar.gz 20836 BLAKE2B c9360890f4ace39564072afa6ee32d5ee5682f1703fbe87eea8b4a04c5575ab5bd63a813f0a86d3c5945429fb9e56693db38a80dec098e4ed7701684f1006570 SHA512 5b82b79ea865381a738f1d77a472d97118f853290fb4fd787537a8dcc7247b33cf8cf507519ad88d55419efa97f86ba9ef3f003b067b1f9cff87e08c2395969b
diff --git a/dev-python/backports-csv/backports-csv-1.0.7.ebuild b/dev-python/backports-csv/backports-csv-1.0.7.ebuild
new file mode 100644 (file)
index 0000000..aa307ff
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Backport of Python 3's 'csv' module"
+HOMEPAGE="https://github.com/ryanhiebert/backports.csv https://pypi.org/project/backports.csv/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND} )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+       "${EPYTHON}" tests.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}