dev-python/enable: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 12:23:07 +0000 (13:23 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 12:36:03 +0000 (13:36 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/enable/Manifest
dev-python/enable/enable-4.4.1.ebuild [deleted file]
dev-python/enable/enable-4.5.1.ebuild [deleted file]
dev-python/enable/files/enable-4.4.1-swig.patch [deleted file]
dev-python/enable/files/enable-4.5.1-doc.patch [deleted file]
dev-python/enable/files/enable-4.5.1-gcc-5.patch [deleted file]
dev-python/enable/files/enable-4.5.1-version.patch [deleted file]

index 4f4928116dc3b625e58eaa23185069a8bcbe2521..0c40428cccdc8a9647d0230e623dbf0dc94e216e 100644 (file)
@@ -1,3 +1 @@
-DIST enable-4.4.1.tar.gz 2507048 BLAKE2B e3414a0505acafece3242a40400aab9ea00062bb605baa500f604df875b1caacd446c30189a23bac856c6cb39067f120be6e89ac9c95a05e92dc882d839a7e4b SHA512 72c879f19e26a4311b900cb4665969b9f806ce47b23c214a25e3ec308cc5300b6d71084a793215b05302fbeba09e13a4561e661c3bddb700d529bd31cfeb4dff
-DIST enable-4.5.1.tar.gz 2571975 BLAKE2B dfd294f80e22fa89243057f405fe83ecadeb3768cae5a103e62219cfc62ecb5bd3acf1bd2d575da3276e8111c5c5330fa88e1ed06c6eb67a04974a57dd0cbd98 SHA512 1095a4490f4918756dd33864aaba2636c294c3b177d3f500d98a355ec86ef86ab211d33cdec95c2d37e7e1df41622acf2c8ecf524a1d93cc39797804c49e6971
 DIST enable-4.7.1.tar.gz 2728889 BLAKE2B 2952c1772ea902b2a040a5dbc1ade4fcb41f38da41cb9cfd3a574d16397fcceedb5d2216e19bd14ca9881ff27efa93ec0fe4b94db8f3baedf174fe062c825f1e SHA512 49ca414d1273fb5ddcb1732e621f91a5ac49ff02d63b5b36b8d9e28dd737eb4a312f35345fc29db555db1c6e0e8c9bf2204f8662b43a2761db6c2d656c6b2140
diff --git a/dev-python/enable/enable-4.4.1.ebuild b/dev-python/enable/enable-4.4.1.ebuild
deleted file mode 100644 (file)
index ad35ba8..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx flag-o-matic
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://docs.enthought.com/enable/
-       https://pypi.org/project/enable/
-       https://github.com/enthought/enable"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/reportlab[${PYTHON_USEDEP}]
-       >=dev-python/traitsui-4[${PYTHON_USEDEP}]
-       >=media-libs/freetype-2
-       virtual/opengl
-       virtual/glu
-       x11-libs/libX11"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-lang/swig:0
-       dev-python/cython[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               media-fonts/font-cursor-misc
-               media-fonts/font-misc-misc
-       )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}"/${P}-swig.patch )
-
-python_prepare_all() {
-       append-cflags -fno-strict-aliasing
-
-       sed -e 's:html_favicon = "et.ico":html_favicon = "_static/et.ico":' \
-               -i docs/source/conf.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       # https://github.com/enthought/enable/issues/158
-       PYTHONPATH=.:kiva \
-               VIRTUALX_COMMAND="nosetests" virtualmake
-       popd > /dev/null
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/enable/enable-4.5.1.ebuild b/dev-python/enable/enable-4.5.1.ebuild
deleted file mode 100644 (file)
index ef3d569..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx flag-o-matic
-
-DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
-HOMEPAGE="http://docs.enthought.com/enable/
-       https://pypi.org/project/enable/
-       https://github.com/enthought/enable"
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/enthought/enable/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="
-       dev-python/apptools[${PYTHON_USEDEP}]
-       dev-python/kiwisolver[${PYTHON_USEDEP}]
-       dev-python/numpy[${PYTHON_USEDEP}]
-       dev-python/reportlab[${PYTHON_USEDEP}]
-       >=dev-python/traitsui-4[${PYTHON_USEDEP}]
-       >=media-libs/freetype-2
-       virtual/opengl
-       virtual/glu
-       x11-libs/libX11"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-lang/swig:0
-       dev-python/cython[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               media-fonts/font-cursor-misc
-               media-fonts/font-misc-misc
-       )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-4.4.1-swig.patch
-       "${FILESDIR}"/${P}-gcc-5.patch
-       "${FILESDIR}"/${P}-doc.patch
-       "${FILESDIR}"/${P}-version.patch
-       )
-
-python_prepare_all() {
-       append-cflags -fno-strict-aliasing
-
-       sed -e 's:html_favicon = "et.ico":html_favicon = "_static/et.ico":' \
-               -i docs/source/conf.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib > /dev/null
-       # https://github.com/enthought/enable/issues/158
-       PYTHONPATH=.:kiva \
-               VIRTUALX_COMMAND="nosetests" virtualmake --verbose
-       popd > /dev/null
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/enable/files/enable-4.4.1-swig.patch b/dev-python/enable/files/enable-4.4.1-swig.patch
deleted file mode 100644 (file)
index a82f3af..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-From f0e399174c5f55eb3a72860c620fdd5193ad57da Mon Sep 17 00:00:00 2001
-From: Jonathan Stickel <jjstickel@gmail.com>
-Date: Wed, 25 Mar 2015 14:05:01 -0600
-Subject: [PATCH] fixes for recent swig
-
----
- kiva/agg/src/affine_matrix.i | 4 ++--
- kiva/agg/src/constants.i     | 4 ++--
- kiva/agg/src/hit_test.i      | 4 ++--
- kiva/agg/src/rgba.i          | 4 ++--
- 4 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/kiva/agg/src/affine_matrix.i b/kiva/agg/src/affine_matrix.i
-index 2f30e51..7c05a6a 100644
---- a/kiva/agg/src/affine_matrix.i
-+++ b/kiva/agg/src/affine_matrix.i
-@@ -157,7 +157,7 @@ namespace agg24
-     };
- };
--%pythoncode {
-+%pythoncode %{
- def is_sequence(arg):
-     try:
-         len(arg)
-@@ -184,7 +184,7 @@ class AffineMatrix(_AffineMatrix):
-         """
-         self.multiply(other)
-         return self
--}
-+%}
- %extend agg24::trans_affine
- {
-diff --git a/kiva/agg/src/constants.i b/kiva/agg/src/constants.i
-index b680cae..78f9d0c 100644
---- a/kiva/agg/src/constants.i
-+++ b/kiva/agg/src/constants.i
-@@ -44,7 +44,7 @@
- unsigned path_cmd(unsigned c);
- unsigned path_flags(unsigned c);
--%pythoncode {
-+%pythoncode %{
- #----------------------------------------------------------------------------
- #
-@@ -141,4 +141,4 @@ interp_enum_map = {}
- for key,value in interp_string_map.items():
-     interp_enum_map[value] = key
--}
-+%}
-diff --git a/kiva/agg/src/hit_test.i b/kiva/agg/src/hit_test.i
-index 76de0c9..2cfb1cf 100644
---- a/kiva/agg/src/hit_test.i
-+++ b/kiva/agg/src/hit_test.i
-@@ -22,7 +22,7 @@ namespace kiva
- }
- %pythoncode
--{
-+%{
- from numpy import shape, transpose, zeros, rank, reshape, int32
- def points_in_polygon(pts, poly_pts, use_winding=False):
-@@ -92,4 +92,4 @@ def points_in_polygon(pts, poly_pts, use_winding=False):
-     else:
-         _agg.points_in_polygon(pts, poly_pts, results)
-     return results    
--}
-+%}
-diff --git a/kiva/agg/src/rgba.i b/kiva/agg/src/rgba.i
-index f7624b8..183014f 100644
---- a/kiva/agg/src/rgba.i
-+++ b/kiva/agg/src/rgba.i
-@@ -74,7 +74,7 @@ namespace agg24
- }
--%pythoncode {
-+%pythoncode %{
- def is_sequence(arg):
-     try:
-         len(arg)
-@@ -90,6 +90,6 @@ class Rgba(_Rgba):
-             if len(args) not in [3,4]:
-                 raise ValueError, "array argument must be 1x3 or 1x4"
-         _Rgba.__init__(self,*args)
--}
-+%}
- %clear double r, double g, double b, double a;
diff --git a/dev-python/enable/files/enable-4.5.1-doc.patch b/dev-python/enable/files/enable-4.5.1-doc.patch
deleted file mode 100644 (file)
index c9cc1ff..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From 41134b03b96b741d95554846841c189313052265 Mon Sep 17 00:00:00 2001
-From: John Wiggins <jwiggins@enthought.com>
-Date: Thu, 1 Oct 2015 20:40:07 +0200
-Subject: [PATCH] Read the docs version directly from enable._version
-
----
- docs/source/conf.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/docs/source/conf.py b/docs/source/conf.py
-index 10b7552..995e315 100644
---- a/docs/source/conf.py
-+++ b/docs/source/conf.py
-@@ -41,8 +41,8 @@
- # The default replacements for |version| and |release|, also used in various
- # other places throughout the built documents.
- d = {}
--execfile(os.path.join('..', '..', 'enable', '__init__.py'), d)
--version = release = d['__version__']
-+execfile(os.path.join('..', '..', 'enable', '_version.py'), d)
-+version = release = d['full_version']
- # There are two options for replacing |today|: either, you set today to some
- # non-false value, then it is used:
diff --git a/dev-python/enable/files/enable-4.5.1-gcc-5.patch b/dev-python/enable/files/enable-4.5.1-gcc-5.patch
deleted file mode 100644 (file)
index 700b0b3..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-From 55a74ccfc33764499497022dd3649be4bb1091ed Mon Sep 17 00:00:00 2001
-From: Nathan Ringo <tikiking1@users.noreply.github.com>
-Date: Wed, 10 Jun 2015 22:06:57 -0500
-Subject: [PATCH] Fixes #200
-
----
- kiva/agg/setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/kiva/agg/setup.py b/kiva/agg/setup.py
-index 5b4d458..c6e290a 100644
---- a/kiva/agg/setup.py
-+++ b/kiva/agg/setup.py
-@@ -170,7 +170,7 @@ def get_ft2_sources((lib_name, build_info), build_dir):
-         f = os.popen("g++ --version")
-         line0 = f.readline()
-         f.close()
--        m = re.match(r'.+?\s(3|4)\.\d+', line0)
-+        m = re.match(r'.+?\s([3-8])\.\d+', line0)
-         if int(m.group(1)) < 4:
-             use_32bit_workaround = True
diff --git a/dev-python/enable/files/enable-4.5.1-version.patch b/dev-python/enable/files/enable-4.5.1-version.patch
deleted file mode 100644 (file)
index 1dd3fe4..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From f91c824ebad74e8c23e62fe3390842c5fe322aee Mon Sep 17 00:00:00 2001
-From: itziakos <ioannist@enthought.com>
-Date: Wed, 20 May 2015 22:52:42 +0100
-Subject: [PATCH] check the enable._version.py when installing from source
-
----
- setup.py | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index f765f51..3328b93 100644
---- a/setup.py
-+++ b/setup.py
-@@ -92,13 +92,14 @@ def write_version_py(filename):
-     fullversion = VERSION
-     if os.path.exists('.git'):
-         git_revision, dev_num = git_version()
--    elif os.path.exists('kiva/_version.py'):
-+    # All packages are synced with the enable version
-+    elif os.path.exists('enable/_version.py'):
-         # must be a source distribution, use existing version file
-         try:
--            from kiva._version import git_revision, full_version
-+            from enable._version import git_revision, full_version
-         except ImportError:
-             raise ImportError("Unable to import git_revision. Try removing "
--                              "kiva/_version.py and the build directory "
-+                              "enable/_version.py and the build directory "
-                               "before building.")
-         match = re.match(r'.*?\.dev(?P<dev_num>\d+)', full_version)