sys-cluster/charliecloud: version bump to 0.9.1.
authorOliver Freyermuth <o.freyermuth@googlemail.com>
Sun, 19 Aug 2018 23:53:58 +0000 (01:53 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 20 Aug 2018 09:44:56 +0000 (11:44 +0200)
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Closes: https://github.com/gentoo/gentoo/pull/9582

sys-cluster/charliecloud/Manifest
sys-cluster/charliecloud/charliecloud-0.9.1.ebuild [new file with mode: 0644]

index 8a9996040096cdca70eed71202c78b98d58f4fc8..6ad96abe61828616ea4da3191704d0647db928d6 100644 (file)
@@ -1,2 +1,3 @@
 DIST charliecloud-0.2.3_pre20171121.tar.gz 82636 BLAKE2B 6eb8465da39dc628d8cf65b475263b6ff12757fec00ede16025c126bc861ab07969fb8a815fbdfa48424911905d59e1290f6281a8d804d069cf940b7a0e66b47 SHA512 1828651d18cd8246e0d462fa966052be21a18f0a7a6bdb76040740dd97b271723c317ed764296cf2d0e554cec527612a02e733ec7bf3e6f4ac73139fed968c83
 DIST charliecloud-0.2.4.tar.gz 178589 BLAKE2B 45330f67e4b116150219a2753f341248878e8fa540583a97c5cd55e42498825e749c5ca9133580c180438898e25dd22bbcec37c31c31258ccf1fa0ffb5814375 SHA512 456b45d071a18562d914e70b141de55950fcf4a5e2aa882b85bdd8c4abab3a62ab1e413c0524a31be2e278328aab67a898f319bd640e9d9a84163efe24e5a872
+DIST charliecloud-0.9.1.tar.gz 194937 BLAKE2B 2ef2ee70cee3293ec4f7f589c9a034afa82835981132ea433d720b2a2750df68adb261540c98bc04e7f8904375dd8804819fb3015dc6e65bbe097fa55d558976 SHA512 6a54912ceb3ea99e9d3d1fa8469d7288df0b71872c6cb1d5a4d324f6f84754b7e4804ec1a3c2a30e7dd6377a3b474fea849eb42014f3599ad27a3f6214642a2b
diff --git a/sys-cluster/charliecloud/charliecloud-0.9.1.ebuild b/sys-cluster/charliecloud/charliecloud-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..f7d1882
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# User namespaces don't play well with the sandbox.
+RESTRICT="test"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+       S="${WORKDIR}/${P}"
+else
+       SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="doc examples +pv test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       pv? ( sys-apps/pv )
+       doc? ( dev-python/sphinx
+              dev-python/sphinx_rtd_theme
+              net-misc/rsync )
+       test? ( app-arch/pigz )"
+
+DOCS=(
+       README.rst
+)
+
+src_compile() {
+       emake
+       use doc && emake -C doc-src
+}
+
+src_install() {
+       emake install PREFIX="${EPREFIX}/usr" DESTDIR="${ED}"
+       if use doc; then
+               mv doc html || die
+               local HTML_DOCS=(html/.)
+       fi
+       if use examples; then
+               docompress -x "${EPREFIX}/usr/share/doc/${PF}/examples"
+               DOCS+=(examples)
+       fi
+       rm -rf "${ED}/usr/share/doc/charliecloud" || die
+       einstalldocs
+}
+
+src_test() {
+       cd "${S}/test" || die
+       export CH_TEST_TARDIR="${T}/tarballs"
+       export CH_TEST_IMGDIR="${T}/images"
+
+       # Do not run tests requiring root.
+       export CH_TEST_PERMDIRS="skip"
+       export CH_TEST_SKIP_DOCKER=yes
+       sed -i 's/CHTEST_HAVE_SUDO=yes/CHTEST_HAVE_SUDO=no/' "${S}/test/common.bash" || die
+
+       emake test-quick
+}