kill some unneeded files; partly fixes bug 166584
authorSimon Stelling <blubb@gentoo.org>
Tue, 13 Feb 2007 14:04:01 +0000 (14:04 +0000)
committerSimon Stelling <blubb@gentoo.org>
Tue, 13 Feb 2007 14:04:01 +0000 (14:04 +0000)
Package-Manager: portage-2.1.2-r9

app-emulation/emul-linux-x86-baselibs/ChangeLog
app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-10.0.ebuild
app-emulation/emul-linux-x86-qtlibs/ChangeLog
app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-10.0.ebuild

index 124ba4b7bc98912a5604f543b8a77946f0af6394..a19bbd06d5dcb7af8cc48e7716c326deb4b00383 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-emulation/emul-linux-x86-baselibs
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/ChangeLog,v 1.64 2007/02/12 09:07:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/ChangeLog,v 1.65 2007/02/13 14:04:01 blubb Exp $
+
+  13 Feb 2007; Simon Stelling <blubb@gentoo.org>
+  emul-linux-x86-baselibs-10.0.ebuild:
+  kill some unneeded files; partly fixes bug 166584
 
   12 Feb 2007; Simon Stelling <blubb@gentoo.org>
   +emul-linux-x86-baselibs-10.0.ebuild:
index cf65060634cd8fc3cf034cd2ea9f91f1e9ef3c93..4c6a9c4a271ce23feef3c91fbc25c6661bbebc2b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-10.0.ebuild,v 1.3 2007/02/12 09:07:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-baselibs/emul-linux-x86-baselibs-10.0.ebuild,v 1.4 2007/02/13 14:04:01 blubb Exp $
 
 DESCRIPTION="Provides precompiled 32bit libraries"
 HOMEPAGE="http://amd64.gentoo.org/emul/content.xml"
@@ -87,13 +87,18 @@ src_unpack() {
 }
 
 src_install() {
-       [[ -d ${S}/etc/revdep-rebuild ]] && rm -rf ${S}/etc/revdep-rebuild
+       # nobody needs *.la, *.h *.a
+       find ${S} -type f -name '*.a' -or -name '*.la' -or -name '*.h' \
+               | xargs rm -f
 
-       if [[ -d ${S}/etc/env.d ]] ; then
-               for f in ${S}/etc/env.d/* ; do
-                       mv -f $f{,-emul}
-               done
-       fi
+       
+       for dir in etc/env.d etc/revdep-rebuild ; do
+               if [[ -d ${S}/${dir} ]] ; then
+                       for f in ${S}/${dir}/* ; do
+                               mv -f $f{,-emul}
+                       done
+               fi
+       done
 
        cp -a "${WORKDIR}"/* "${D}"/ || die "copying files failed!"
 }
index 222a595ffc1a5cf175de73716dd61b1c52098fa1..81a0e6ce0fb30d340f6d26e0ecc0d41462480715 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-emulation/emul-linux-x86-qtlibs
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/ChangeLog,v 1.25 2007/02/12 09:11:20 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/ChangeLog,v 1.26 2007/02/13 14:04:00 blubb Exp $
+
+  13 Feb 2007; Simon Stelling <blubb@gentoo.org>
+  emul-linux-x86-qtlibs-10.0.ebuild:
+  kill some unneeded files; partly fixes bug 166584
 
 *emul-linux-x86-qtlibs-10.0 (12 Feb 2007)
 
index c22f0427c037f0503151b95387a73cccf0114898..a9848ee7cdc4fc0aa18e660dc1f20aaa14967ce3 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-10.0.ebuild,v 1.1 2007/02/12 09:11:20 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-qtlibs/emul-linux-x86-qtlibs-10.0.ebuild,v 1.2 2007/02/13 14:04:00 blubb Exp $
 
 DESCRIPTION="Provides precompiled 32bit libraries"
 HOMEPAGE="http://amd64.gentoo.org/emul/content.xml"
@@ -43,13 +43,17 @@ src_unpack() {
 }
 
 src_install() {
-       [[ -d ${S}/etc/revdep-rebuild ]] && rm -rf ${S}/etc/revdep-rebuild
-       
-       if [[ -d ${S}/etc/env.d ]] ; then
-               for f in ${S}/etc/env.d/* ; do
-                       mv -f $f{,-emul}
-               done
-       fi
+        # nobody needs *.la, *.h *.a
+        find ${S} -type f -name '*.a' -or -name '*.la' -or -name '*.h' \
+               | xargs rm -f
+
+       for dir in etc/env.d etc/revdep-rebuild ; do
+               if [[ -d ${S}/${dir} ]] ; then
+                       for f in ${S}/${dir}/* ; do
+                               mv -f $f{,-emul}
+                       done
+               fi
+       done
 
        cp -a "${WORKDIR}"/* "${D}"/ || die "copying files failed!"
 }