net-misc/youtube-dl: Old
authorJeroen Roovers <jer@gentoo.org>
Sat, 19 Oct 2019 10:39:03 +0000 (12:39 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 19 Oct 2019 10:39:14 +0000 (12:39 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2019.09.28.ebuild [deleted file]

index a8355be3f7cd6175e4c7823c258f51deab5e560e..bb6ab5d5498bd148ec19e8c4434831feff86896d 100644 (file)
@@ -1,2 +1 @@
-DIST youtube-dl-2019.09.28.tar.gz 3181163 BLAKE2B e3e7b166f07cbbbe8f77c7116254000d5c864efcc2701533a7f7aa296450323a27072509acabd5a1be27c5aab208037e5545aa21e152b14ea0374e1c629c3ef5 SHA512 b5d5034f9ace17ee18b550b825431797b49d1f916963d483c95a737a3f2842c4c916f6d24f2056efbb786ed3c2ddf269f28f736a650a47b7ff0f94256aba4e94
 DIST youtube-dl-2019.10.16.tar.gz 3183413 BLAKE2B b2795c5e66c0e787c9186e928f95568323d89e0724929219784b6a0cb2799d5d4069e6c4eca7af277e2bfce6129fe474af139be09da1cc2f29053c9a41f16504 SHA512 b8e0068c2c29d0475ddbe03244adc8312c114d2b5a084763d4a49fb583e003d42187c0b7b728150c5fb815b08780dfd3cbb44b3e86c557f462e885127776efca
diff --git a/net-misc/youtube-dl/youtube-dl-2019.09.28.ebuild b/net-misc/youtube-dl/youtube-dl-2019.09.28.ebuild
deleted file mode 100644 (file)
index 8b7913f..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-LICENSE="public-domain"
-
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-RESTRICT="test"
-SLOT="0"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-RDEPEND="
-       ${DEPEND}
-       || (
-               dev-python/pycryptodome[${PYTHON_USEDEP}]
-               dev-python/pycrypto[${PYTHON_USEDEP}]
-       )
-"
-S="${WORKDIR}/${PN}"
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins ${PN}.zsh _${PN}
-
-       insinto /usr/share/fish/vendor_completions.d
-       doins ${PN}.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
-       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
-       elog "videos can be retrieved in a higher quality format without sound."
-       elog "${PN} will detect whether avconv/ffmpeg is present and"
-       elog "automatically pick the best option."
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-       elog
-       elog "If you want ${PN} to embed thumbnails from the metadata into the"
-       elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}