media-gfx/rawtherapee: version bump to 5.8
authorFrancesco Riosa <friosa@gaikai.com>
Fri, 7 Feb 2020 09:43:34 +0000 (09:43 +0000)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 26 Feb 2020 18:35:27 +0000 (19:35 +0100)
Signed-off-by: Francesco Riosa <vivo75@gmail.com>
Closes: https://bugs.gentoo.org/708202
Closes: https://github.com/gentoo/gentoo/pull/14590
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/rawtherapee/Manifest
media-gfx/rawtherapee/rawtherapee-5.8.ebuild [new file with mode: 0644]

index 7026f26c132c3b64d54a635496aea56f643c254a..dd0e0a324de14ad58e0b7be82ec1ecf0082799d1 100644 (file)
@@ -1,2 +1,3 @@
 DIST rawtherapee-5.6.tar.xz 12083264 BLAKE2B a0eb09e98e1041b393ad3aa671641a2a4855379cef6245ca3cca2588ff5f50fedf8becd88bad1ab70f63dfb575f5f22c141040defa10b47268947415999d8e79 SHA512 2c751c7631ea2ef65c334fa0baab16d4c3161fae66487870c476f07f1ea3604a5e28a251fd98d9688cafc088302af7aa6e28e9b27a37f916715708ed5e731f0f
 DIST rawtherapee-5.7.tar.xz 12092496 BLAKE2B 40d97d09106d7d2b843376b4c58daac87f99315604bd8e704e1f231c17d01896cd732da2449f84a59ed221fbf6a929a5db8e728977431fdcc07f3d30120b633a SHA512 8101ec66d9be4cab0c0b91336a3f83a32a6220a2f342f1c74d604c15686ee08bc7dbc090232916f13d5436957d800b64b284a8a9d3352f2f721266b07e005162
+DIST rawtherapee-5.8.tar.xz 12653148 BLAKE2B f6d4b9b177ad3b6a32b460ecfc7caf5d42a01b5dd4f24da29739f5a2e5936a8d36f9857c0e24bca11f077ab0626f08bbad59ef756792d12f93ef9516427cd2c4 SHA512 bc79586cd937dcaefc053e65faa2162de887d514e44980956d937c157c6d55c4f6e6a7a9b8f91f2d657ed2054814737b96d5d741674c1e5a961d7177433efe4e
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8.ebuild
new file mode 100644 (file)
index 0000000..425c6e3
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp tcmalloc"
+
+RDEPEND="
+       dev-libs/expat
+       dev-libs/libsigc++:2
+       media-libs/lcms:2
+       media-libs/lensfun
+       media-libs/libcanberra[gtk3]
+       media-libs/libiptcdata
+       media-libs/libpng:0=
+       media-libs/tiff:0
+       sci-libs/fftw:3.0=
+       sys-libs/zlib
+       virtual/jpeg:0
+       x11-libs/gtk+:3
+       tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}
+       dev-cpp/gtkmm:3.0
+       gnome-base/librsvg"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+       if use openmp ; then
+               tc-has-openmp || die "Please switch to an openmp compatible compiler"
+       fi
+}
+
+src_configure() {
+       # upstream tested that "fast-math" give wrong results, so filter it
+       # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+       filter-flags -ffast-math
+       # -Ofast enable "fast-math" both in gcc and clang
+       replace-flags -Ofast -O3
+       # In case we add an ebuild for klt we can (i)use that one,
+       # see http://cecas.clemson.edu/~stb/klt/
+       local mycmakeargs=(
+               -DOPTION_OMP=$(usex openmp)
+               -DDOCDIR=/usr/share/doc/${PF}
+               -DCREDITSDIR=/usr/share/${PN}
+               -DLICENCEDIR=/usr/share/${PN}
+               -DCACHE_NAME_SUFFIX=""
+               -DWITH_SYSTEM_KLT="off"
+               -DENABLE_TCMALLOC=$(usex tcmalloc)
+       )
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+}