app-laptop/tpacpi-bat: Version bump (close #86 gh)
authorMarius Brehler <marbre@linux.sungazer.de>
Sat, 12 Sep 2015 12:42:06 +0000 (14:42 +0200)
committerChristoph Junghans <ottxor@gentoo.org>
Sun, 13 Sep 2015 18:12:13 +0000 (12:12 -0600)
Package-Manager: portage-2.2.20.1

app-laptop/tpacpi-bat/Manifest
app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild [new file with mode: 0644]

index 2f013be7fce279ec014120076b9a61f1d9237f6a..ac2c290b9137da49ad89465da53b1da4878854fa 100644 (file)
@@ -1,2 +1,3 @@
 DIST tpacpi-bat-1.1.tar.gz 17781 SHA256 99bfeae60c672d981ea70a98470b8c2a1a9da52da0fce7f669270f216d2230a3 SHA512 7b8838e6db7f98cd5bb674a99dbb880ba6574529de68d97ce704bf225ba416183971aae3c2dd623bc8750767c54a2a52cd0b525bce70640ecf0b307fdba03821 WHIRLPOOL 3a057e57da77f997ed27f679c2503a139d760949027c02aa5dd5bef71579d525acc866655e0008b59ef6ae8b0c567f7de627838baac5c7ed2969523a7355a879
 DIST tpacpi-bat-2.1.tar.gz 17753 SHA256 0a4b273215ef814a1932b0c8ff1571c6e45eecb3b28d8462deab460f0bcdc337 SHA512 7ed4974d84c3f1ddc9fd5cd6d7f103a11e2f808a223692749e3ae0ec2e888b62083d577214e27634cd76e9b616a6b8d5cb5474ddb64f73972d08641051c5c6f8 WHIRLPOOL 303c28a287b657514e985227b8f4c9c3d044fdf46a7dca0e52ce3ab7b6852a65aa46a8805cf6a945b3936432d3c3e43855d0d88c7549b05e95d271e8c605b1b7
+DIST tpacpi-bat-3.0.tar.gz 18137 SHA256 f9aa8be181df6a7d41eac6224abb6dadf1d147022449e9159c4aa09397b7a485 SHA512 2beab3e5495f028b53d673a4243a2128f4ff85e19e18ac7d53663a1d62e20b271442d6c2c8f19cb41d618ddf7ebb4d9b8390f7f185f77bdca33c69bb19463128 WHIRLPOOL 9329ea83fdd0913cc47446895e6ab385f09ca42e7a19533b5c7fa44cb62bebd07ba24f89b0deacc89d6b3aff3ff826f2a53f8d2e918f137d0f6215aa6eaa9198
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-3.0.ebuild
new file mode 100644 (file)
index 0000000..06144e8
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd
+
+if [ "${PV}" = "9999" ]; then
+       inherit git-2
+       EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git https://github.com/teleshoes/tpacpi-bat.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+       dev-lang/perl"
+
+src_install() {
+       dodoc README battery_asl
+       dobin tpacpi-bat
+       newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
+       systemd_newunit tpacpi.service ${PN}.service
+}