net-vpn/openvpn: drop broken USE=static flag, bug #704100
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 2 Mar 2020 14:38:26 +0000 (14:38 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 2 Mar 2020 14:38:26 +0000 (14:38 +0000)
'-Xcompiler -static' is understood by libtool, but not gcc directly.
That makes 'append-ldflags -Xcompiler -static' call always fail ./configure
as:

```
configure: error: C compiler cannot create executables
See `config.log' for more details
```

Reported-by: Rolf Eike Beer
Closes: https://bugs.gentoo.org/704100
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-vpn/openvpn/openvpn-2.4.6-r1.ebuild
net-vpn/openvpn/openvpn-2.4.6.ebuild
net-vpn/openvpn/openvpn-2.4.7-r1.ebuild
net-vpn/openvpn/openvpn-9999.ebuild

index 0c785a1bb8e7707470e9758aba1b6f49209cf514..da73ce7b6eb7371b8f0d5b75fd83f9f67636d0c2 100644 (file)
@@ -15,11 +15,10 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
 
 IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
-IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="static? ( !plugins !pkcs11 )
-       pkcs11? ( ssl )
+REQUIRED_USE="pkcs11? ( ssl )
        !plugins? ( !pam !down-root )
        inotify? ( plugins )"
 
@@ -66,7 +65,6 @@ src_prepare() {
 }
 
 src_configure() {
-       use static && append-ldflags -Xcompiler -static
        SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
        TMPFILES_DIR="/usr/lib/tmpfiles.d" \
        IFCONFIG=/bin/ifconfig \
index 90fc9bfde6548c6149bd04ecc89d2f9fa45f2c15..f7489160c24d0ccb02d2c90e9c28105d0023e6fc 100644 (file)
@@ -15,11 +15,10 @@ SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
 
 IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
-IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="static? ( !plugins !pkcs11 )
-       pkcs11? ( ssl )
+REQUIRED_USE="pkcs11? ( ssl )
        !plugins? ( !pam !down-root )
        inotify? ( plugins )"
 
@@ -66,7 +65,6 @@ src_prepare() {
 }
 
 src_configure() {
-       use static && append-ldflags -Xcompiler -static
        SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
        TMPFILES_DIR="/usr/lib/tmpfiles.d" \
        IFCONFIG=/bin/ifconfig \
index 7463968b82f714c470a2e8dc9c192f1982454871..7c4fa29d88606d18d86602959a0e20b0115541dc 100644 (file)
@@ -15,11 +15,10 @@ SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
 
 IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
-IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="static? ( !plugins !pkcs11 )
-       pkcs11? ( ssl )
+REQUIRED_USE="pkcs11? ( ssl )
        !plugins? ( !pam !down-root )
        inotify? ( plugins )"
 
@@ -67,7 +66,6 @@ src_prepare() {
 }
 
 src_configure() {
-       use static && append-ldflags -Xcompiler -static
        SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
        TMPFILES_DIR="/usr/lib/tmpfiles.d" \
        IFCONFIG=/bin/ifconfig \
index bd047290162374303dd0de4f330f95be79793c60..19122b752be614507cbd88987e571272ddaf3d4d 100644 (file)
@@ -15,11 +15,10 @@ SLOT="0"
 KEYWORDS=""
 
 IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
-IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+IUSE+=" pkcs11 +plugins selinux +ssl systemd test userland_BSD"
 
 RESTRICT="!test? ( test )"
-REQUIRED_USE="static? ( !inotify !plugins !pkcs11 )
-       lzo? ( !lz4 )
+REQUIRED_USE="lzo? ( !lz4 )
        !plugins? ( !pam !down-root )
        inotify? ( plugins )"
 
@@ -61,7 +60,6 @@ src_prepare() {
 }
 
 src_configure() {
-       use static && append-ldflags -Xcompiler -static
        SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
        TMPFILES_DIR="/usr/lib/tmpfiles.d" \
        econf \