net-misc/nyx: EAPI 7; add pypy3 support
authorJeffrey Lin <jeffrey@icurse.nl>
Sun, 23 Feb 2020 03:52:03 +0000 (22:52 -0500)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 10 May 2020 16:45:59 +0000 (18:45 +0200)
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-misc/nyx/nyx-2.1.0-r1.ebuild

index a95caeb5ea5ff03f713db121d3b37a9baeda90aa..39a256ecefe0ab9e446d61ecc2507d58499a96a8 100644 (file)
@@ -1,11 +1,13 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8} pypy3)
 PYTHON_REQ_USE='sqlite(-)'
+DISTUTILS_USE_SETUPTOOLS=rdepend
 
-inherit vcs-snapshot distutils-r1
+inherit distutils-r1
 
 DESCRIPTION="Utility to monitor real time Tor status information"
 HOMEPAGE="https://nyx.torproject.org"
@@ -22,8 +24,6 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="
        net-libs/stem[${PYTHON_USEDEP}]
        net-vpn/tor"