dev-util/cdiff: Clarify description
authorJustin Lecher <jlec@gentoo.org>
Wed, 9 Dec 2015 11:57:43 +0000 (12:57 +0100)
committerJustin Lecher <jlec@gentoo.org>
Wed, 9 Dec 2015 12:01:29 +0000 (13:01 +0100)
Clean live ebuild code from normal ebuilds

Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567826

Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-util/cdiff/cdiff-0.9.6.ebuild
dev-util/cdiff/cdiff-9999.ebuild

index 251fa11f3f558ceb7c141ef303c6919b3d03a655..e16cd6efad2feaee0ec26de721b377c9738c3c2b 100644 (file)
@@ -8,20 +8,14 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
 
 inherit distutils-r1
 
-if [[ "${PV}" != *"9999"* ]] ; then
-       KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-else
-       KEYWORDS=""
-       EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
-       inherit git-r3
-fi
-
-DESCRIPTION="Colored, side-by-side diff terminal viewer"
+DESCRIPTION="Term based view of colored, incremental diff in a Git/Mercurial/Svn workspace"
 HOMEPAGE="https://github.com/ymattw/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
 
 DEPEND="
        !<app-misc/colordiff-1.0.13-r1
index 8bbe3dd2c8cc074fdae2ba6af4863cda71313805..dba6398baf807c17ae616ee7ada132f2fb2a452f 100644 (file)
@@ -4,30 +4,23 @@
 
 EAPI="5"
 
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
 
-inherit distutils-r1
+inherit distutils-r1 git-r3
 
-if [[ "${PV}" != *"9999"* ]] ; then
-       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-else
-       KEYWORDS=""
-       EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
-       inherit git-r3
-fi
-
-DESCRIPTION="Colored, side-by-side diff terminal viewer"
+DESCRIPTION="Term based view of colored, incremental diff in a Git/Mercurial/Svn workspace"
 HOMEPAGE="https://github.com/ymattw/${PN}"
+EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
 
 LICENSE="BSD"
 SLOT="0"
+KEYWORDS=""
+IUSE=""
 
 DEPEND="
        !<app-misc/colordiff-1.0.13-r1
        dev-python/setuptools[${PYTHON_USEDEP}]
        sys-apps/less"
-
 RDEPEND="${DEPEND}"
 
 PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )