dev-ruby/rspectacular: add ruby27
authorHans de Graaff <graaff@gentoo.org>
Mon, 13 Apr 2020 13:08:21 +0000 (15:08 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 13 Apr 2020 13:08:57 +0000 (15:08 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild b/dev-ruby/rspectacular/rspectacular-0.70.8-r1.ebuild
new file mode 100644 (file)
index 0000000..1140663
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://github.com/thekompanee/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2 dev-ruby/shoulda-matchers:3"