Version bump, newer version than mentioned in bump bug #159631. Clean out older version.
authorPatrick McLean <chutzpah@gentoo.org>
Mon, 1 Jan 2007 23:12:27 +0000 (23:12 +0000)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 1 Jan 2007 23:12:27 +0000 (23:12 +0000)
Package-Manager: portage-2.1.2_rc4-r1

sys-fs/ntfs3g/ChangeLog
sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102 [new file with mode: 0644]
sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild [new file with mode: 0644]

index 3e1af5f61f530e7439fa170fe3b5d95fe067f833..cf350460258a6293030e6f39bf9caa9ffeea2388 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-fs/ntfs3g
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.17 2006/12/13 15:22:32 chutzpah Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.18 2007/01/01 23:12:27 chutzpah Exp $
+
+*ntfs3g-0.20070102 (01 Jan 2007)
+
+  01 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+  -ntfs3g-0.20061115-r1.ebuild, +ntfs3g-0.20070102.ebuild:
+  Version bump, newer version than mentioned in bump bug #159631. Clean out
+  older version.
 
 *ntfs3g-0.20061212 (13 Dec 2006)
 
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102
new file mode 100644 (file)
index 0000000..2f04a4f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3f03bae2ef34c7adb7a3aece6c921f94 ntfs-3g-0.20070102-BETA.tgz 561276
+RMD160 54e5504ebe624e180e9aadf8d1826e5844e46ed8 ntfs-3g-0.20070102-BETA.tgz 561276
+SHA256 28f1fc26257802055275976dd9c606ac913d3caedd3c0a7b28538d234da8fee6 ntfs-3g-0.20070102-BETA.tgz 561276
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild
new file mode 100644 (file)
index 0000000..798be40
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild,v 1.1 2007/01/01 23:12:27 chutzpah Exp $
+
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="!FUSE_FS"
+ERR=" ${BAD}*${NORMAL}  "
+ERROR_FUSE_FS="For this version of ntfs-3g to work properly, you need to use the
+$ERR kernel module included in the package, not the kernel version. To do this
+$ERR remove FUSE from your kernel, recompile it then remerge FUSE.
+$ERR
+$ERR    emerge -a1 sys-fs/fuse
+$ERR
+$ERR You will need to reboot if you had FUSE in your kernel, if it was a module, this
+$ERR should be enough:
+$ERR
+$ERR    modprobe -r fuse
+$ERR    modprobe fuse
+$ERR
+$ERR If either of these commands have an error, you will need to reboot.
+$ERR"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # default makefile calls ldconfig
+       sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "install failed"
+       dodoc AUTHORS ChangeLog CREDITS NEWS README
+}