dev-python/python3-saml: New package
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 25 Feb 2020 01:40:10 +0000 (17:40 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 25 Feb 2020 02:05:07 +0000 (18:05 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/python3-saml/Manifest [new file with mode: 0644]
dev-python/python3-saml/metadata.xml [new file with mode: 0644]
dev-python/python3-saml/python3-saml-1.9.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
new file mode 100644 (file)
index 0000000..23148cd
--- /dev/null
@@ -0,0 +1 @@
+DIST python3-saml-1.9.0.tar.gz 497106 BLAKE2B c3b282be835dcd0590125563ed0380bbb5d486aeffd60fa0d6a1e7d22b25ffaa03a1bea555520b1465b27b352df0936d21b919ce73a3671d63f07a52b3efdb37 SHA512 a5171258b917c02f10a0c420a19fe6829a034df1dfd87135351b9c187314dca2f973012f49056f391444aba76306adfd48cd77a859274d5cbd2a8c23a00af78d
diff --git a/dev-python/python3-saml/metadata.xml b/dev-python/python3-saml/metadata.xml
new file mode 100644 (file)
index 0000000..56cae16
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python3-saml/python3-saml-1.9.0.ebuild b/dev-python/python3-saml/python3-saml-1.9.0.ebuild
new file mode 100644 (file)
index 0000000..b387635
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+       https://pypi.org/project/python3-saml/"
+SRC_URI="https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+       dev-python/isodate[${PYTHON_USEDEP}]
+       dev-python/python-xmlsec[${PYTHON_USEDEP}]
+       dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               dev-python/freezegun[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="${CDEPEND}"
+
+distutils_enable_tests setup.py