net-analyzer/nagios-plugin-check_lm_sensors: new pkg, v4.1.1_p20170912
authorLouis Sautier <sbraz@gentoo.org>
Mon, 21 Jan 2019 13:44:46 +0000 (14:44 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 23 Jan 2019 17:28:11 +0000 (18:28 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
net-analyzer/nagios-plugin-check_lm_sensors/Manifest [new file with mode: 0644]
net-analyzer/nagios-plugin-check_lm_sensors/metadata.xml [new file with mode: 0644]
net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20170912.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/nagios-plugin-check_lm_sensors/Manifest b/net-analyzer/nagios-plugin-check_lm_sensors/Manifest
new file mode 100644 (file)
index 0000000..1dcf0ec
--- /dev/null
@@ -0,0 +1 @@
+DIST nagios-plugin-check_lm_sensors-4.1.1_p20170912.tar.gz 21681 BLAKE2B 7144c9b9fc4a2b2ccd964ce356809e8ea393b05f86015e5efe5b0ef70fccb585d520fdbba486fd1637c0ef9d2853d270cfb069f6bed22a105b5d80977a8481d7 SHA512 7870e29f58179bd71c917c2bcfe7ff0ee9f28be8b41b19b8f4f3e623fc3ca12395d6dbd55eef3f4084b3fedf2b1c4dc745357d045d19e1f00a3fe2e24a236e77
diff --git a/net-analyzer/nagios-plugin-check_lm_sensors/metadata.xml b/net-analyzer/nagios-plugin-check_lm_sensors/metadata.xml
new file mode 100644 (file)
index 0000000..3ded77e
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>sbraz@gentoo.org</email>
+               <name>Louis Sautier</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">matteocorti/check_lm_sensors</remote-id>
+               <bugs-to>https://github.com/matteocorti/check_lm_sensors/issues</bugs-to>
+       </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20170912.ebuild b/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20170912.ebuild
new file mode 100644 (file)
index 0000000..4587bb0
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module vcs-snapshot
+
+MY_PN="${PN/nagios-plugin-/}"
+MY_COMMIT="36e453f791f0c8e32c2ead204f68511fd2ad4529"
+
+DESCRIPTION="Nagios plugin to monitor the values of onboard sensors and disk temperatures"
+HOMEPAGE="https://github.com/matteocorti/check_lm_sensors"
+SRC_URI="https://github.com/matteocorti/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-perl/Module-Install"
+RDEPEND="
+       dev-perl/Monitoring-Plugin
+       virtual/perl-Getopt-Long
+"
+
+src_compile() {
+       default
+       pod2man ${MY_PN}.pod > ${MY_PN}.1 || die
+}
+
+src_install() {
+       perl-module_src_install
+       doman ${MY_PN}.1
+       local plugindir="/usr/$(get_libdir)/nagios/plugins"
+       dodir "${plugindir}"
+       mv "${ED}/usr/bin/${MY_PN}" "${ED}/${plugindir}" || die
+}