Version cleanup, and added patch to 0.3.7 prevent an error if no Rox-Filer Options...
authorJim Ramsay <lack@gentoo.org>
Mon, 20 Nov 2006 20:25:46 +0000 (20:25 +0000)
committerJim Ramsay <lack@gentoo.org>
Mon, 20 Nov 2006 20:25:46 +0000 (20:25 +0000)
Package-Manager: portage-2.1.2_rc1-r6

rox-base/tasktray/ChangeLog
rox-base/tasktray/files/digest-tasktray-0.3.7-r1 [new file with mode: 0644]
rox-base/tasktray/files/tasktray-0.3.7-theme_not_set.patch [new file with mode: 0644]
rox-base/tasktray/tasktray-0.3.7-r1.ebuild [new file with mode: 0644]

index a36ad4810d732312dbe4cd8d64278238b7e73402..7a3056187795733c6424d02efd987f47c90d0a94 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for rox-base/tasktray
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/tasktray/ChangeLog,v 1.5 2006/11/20 18:16:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/tasktray/ChangeLog,v 1.6 2006/11/20 20:25:46 lack Exp $
+
+*tasktray-0.3.7-r1 (20 Nov 2006)
+
+  20 Nov 2006; Jim Ramsay <lack@gentoo.org>
+  +files/tasktray-0.3.7-theme_not_set.patch, -tasktray-0.3.5.ebuild,
+  -tasktray-0.3.7.ebuild, +tasktray-0.3.7-r1.ebuild:
+  Version cleanup, and added patch to prevent an error if no Rox-Filer Options
+  file is currently in existence
 
   20 Nov 2006; Christian Faulhammer <opfer@gentoo.org>
   tasktray-0.3.6.ebuild:
diff --git a/rox-base/tasktray/files/digest-tasktray-0.3.7-r1 b/rox-base/tasktray/files/digest-tasktray-0.3.7-r1
new file mode 100644 (file)
index 0000000..7b7f646
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c5dbccf1f2790a3d40c0eb967afdfded TaskTray-0.3.7.tgz 23028
+RMD160 60184e0364e814737683ffe9fcdb81f599dce430 TaskTray-0.3.7.tgz 23028
+SHA256 eb5d6fceb7477b45a4aab5b2e2ee59a18403902d05d82b6637a9b345d1650adc TaskTray-0.3.7.tgz 23028
diff --git a/rox-base/tasktray/files/tasktray-0.3.7-theme_not_set.patch b/rox-base/tasktray/files/tasktray-0.3.7-theme_not_set.patch
new file mode 100644 (file)
index 0000000..71429ef
--- /dev/null
@@ -0,0 +1,20 @@
+--- TaskTray/AppletRun.orig    2006-11-20 13:38:01.000000000 -0600
++++ TaskTray/AppletRun 2006-11-20 13:38:53.000000000 -0600
+@@ -326,6 +326,8 @@
+ def reload_icons(ign):
+       rox_options = options.OptionGroup('ROX-Filer', 'Options', 'rox.sourceforge.net')
+       rox_o_icon_theme = options.Option('icon_theme', 'ROX', rox_options)
++      if rox_o_icon_theme.value is None:
++              rox_o_icon_theme.value = ""
+       icon_theme = g.IconTheme()
+       icon_theme.set_custom_theme(rox_o_icon_theme.value)
+       for class_group in icons.keys():
+@@ -357,6 +359,8 @@
+ icon_theme = g.IconTheme()
+ rox_options = options.OptionGroup('ROX-Filer', 'Options', 'rox.sourceforge.net')
+ rox_o_icon_theme = options.Option('icon_theme', 'ROX', rox_options)
++if rox_o_icon_theme.value is None:
++      rox_o_icon_theme.value = ""
+ icon_theme.set_custom_theme(rox_o_icon_theme.value)
+ debug("Icon Theme: %s" % rox_o_icon_theme.value)
+ #rox_options.add_notify(rox_options_changed)
diff --git a/rox-base/tasktray/tasktray-0.3.7-r1.ebuild b/rox-base/tasktray/tasktray-0.3.7-r1.ebuild
new file mode 100644 (file)
index 0000000..d37f078
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/tasktray/tasktray-0.3.7-r1.ebuild,v 1.1 2006/11/20 20:25:46 lack Exp $
+
+ROX_LIB_VER=1.9.6
+inherit rox
+
+MY_PN="TaskTray"
+DESCRIPTION="TaskTray is a rox panel applet to show running applications."
+HOMEPAGE="http://rox4debian.berlios.de"
+SRC_URI="ftp://ftp.berlios.de/pub/rox4debian/apps/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/gnome-python-desktop-2.12"
+
+APPNAME="${MY_PN}"
+S="${WORKDIR}"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       epatch "${FILESDIR}"/${P}-theme_not_set.patch
+}