media-video/dvdimagecmp: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 19:00:22 +0000 (20:00 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 19:11:19 +0000 (20:11 +0100)
Bug: https://bugs.gentoo.org/697264
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/dvdimagecmp/dvdimagecmp-0.3-r1.ebuild

index 17bd464ecd1a92e9d4fa83dc8d0140bc43ae22a0..de6ad2452c5f58044cfa4ee8add965d8504cab3c 100644 (file)
@@ -1,29 +1,26 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs flag-o-matic
-
-IUSE=""
+inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="Tool to compare a burned DVD with an image to check for errors"
 HOMEPAGE="http://panteltje.com/panteltje/dvd/"
 SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
+IUSE=""
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${P}.diff"
-}
+PATCHES=(
+       "${FILESDIR}/${P}.diff"
+)
 
 src_compile() {
-       append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+       append-lfs-flags
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
 }
 
 src_install() {