dev-java/openjdk-bin: drop 11_p28
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 28 Jan 2019 01:39:04 +0000 (17:39 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 28 Jan 2019 03:23:09 +0000 (19:23 -0800)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk-bin/Manifest
dev-java/openjdk-bin/openjdk-bin-11_p28.ebuild [deleted file]

index 8e4b58d42c37dfc6d8d807460fca97897d0ab742..b22583da608755b80df8d31ff1640e23d384c79a 100644 (file)
@@ -1,6 +1,3 @@
-DIST OpenJDK11-jdk_aarch64_linux_hotspot_11_28.tar.gz 193328951 BLAKE2B f7586ed6b5e5562f6b1b4ed155abadbe31cb85459c982b0011e75d85046261c0a78dcaab343fb5c5c7a382c3fd1ac52caefc8194262e35c3601b9aae5a9b94e3 SHA512 b2e5bd25fd62425e25a9a60cd2ca4b080748a352c04c29f206ab121245226c61fa5a8573d342d8bf88efd83a9a7890fd85cf90d700dae28f632878a60d79ea75
-DIST OpenJDK11-jdk_ppc64le_linux_hotspot_11_28.tar.gz 176285783 BLAKE2B a64f86a4f69302efe0eb2645d39c44ce89bcf58c765c12c109735fb2ede5959b0659d4b9f85cf8e79102fc6f00443b99a78fc5745086b1b5e16bd41958db1ed7 SHA512 84eb35634a985647d4fc90c6c4a1855c1c059e5fde8cf3ef7665fa754a7549cb3905a1c35710c6c936426efd6e0bc1ac773fbef11550dbadbff622fd2c201d74
-DIST OpenJDK11-jdk_x64_linux_hotspot_11_28.tar.gz 195689094 BLAKE2B 4d65b7993fddd113964103a1066faa6e7e83ab7807f6403c1f5bc5a72ca82dc51287d4911e264ba5754b7c1184aa1f1d1c94d19ae242ab02bf238f6c359c0de3 SHA512 f7a427bc33b2e8a2f68c7955b23d14f2eacf7b526f2990b29e55bdb1ae96d3e14f3d7c169c76ba4b18fd8195cef81d7199a37a81ce73d6b21a72f07388e70793
 DIST OpenJDK11U-jdk_aarch64_linux_hotspot_11.0.1_13.tar.gz 193388219 BLAKE2B 21ff9bcd5288a17ff7f660fb9b1bbb6c38589fea72850729227a985dce1966c6d0b0d6c64ad6885c17612d215e58a50cec5f70205877bb26c70924b15f92886b SHA512 200ebd5882e2ebd315a2d0fdd800d70b52d468022ae565756ccd56e1fdd2464b459753cfad6c5f46a61cdda8a003cdfe031c2a6a12e047bbe7ee2133dd048546
 DIST OpenJDK11U-jdk_aarch64_linux_hotspot_11.0.2_7.tar.gz 194181157 BLAKE2B 7883e6846670c87f4ed8338804671bff19ba2910e1e96eacd9729f2ba64e9c6b460d300080e3cd3a4f94722ff9942832681bf23f64e9401e07d824028614874f SHA512 d982d4ba8c1b99b8685b36b9c0b6bb6ff8f8ec04de74945876915e01827fb389ad72d868c387f0ef4d5dd1a21cb09170b0d14ca33a2c2ec0c1f95c09fc1a475a
 DIST OpenJDK11U-jdk_ppc64le_linux_hotspot_11.0.1_13.tar.gz 179520284 BLAKE2B 32acf913aa1b176ca98af0c6111e7f14bba22b84547e24dac279205bb0c81fc3845239e9e34c897c18452ebbb4c71b8185fc4d7d3a2856f3cc767ed4c268d61c SHA512 3bf9fa8eb4cdad03dbbb648b6ab1d8ed5ed34584abe2bec254626952aeba2fc5d492075ba0308ab8e28824959df5f11bb46ec1638c2588b352dd58a5097c030a
diff --git a/dev-java/openjdk-bin/openjdk-bin-11_p28.ebuild b/dev-java/openjdk-bin/openjdk-bin-11_p28.ebuild
deleted file mode 100644 (file)
index bb324e5..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-vm-2
-
-abi_uri() {
-       echo "${2-$1}? (
-                       https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}-jdk_${1}_linux_hotspot_${MY_PV//[.+]/_}.tar.gz
-               )"
-}
-
-MY_PV=${PV/_p/+}
-SLOT=${MY_PV%%[.+]*}
-
-SRC_URI="
-       $(abi_uri x64 amd64)
-       $(abi_uri aarch64 arm64)
-       $(abi_uri ppc64le ppc64)
-"
-
-DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
-HOMEPAGE="https://adoptopenjdk.net"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-IUSE="alsa cups doc examples +gentoo-vm headless-awt nsplugin selinux source +webstart"
-RESTRICT="preserve-libs"
-QA_PREBUILT="*"
-
-RDEPEND="
-       media-libs/fontconfig:1.0
-       media-libs/freetype:2
-       >=sys-libs/glibc-2.2.5:*
-       sys-libs/zlib
-       alsa? ( media-libs/alsa-lib )
-       cups? ( net-print/cups )
-       doc? ( dev-java/java-sdk-docs:${SLOT} )
-       selinux? ( sec-policy/selinux-java )
-       !headless-awt? (
-               x11-libs/libX11
-               x11-libs/libXext
-               x11-libs/libXi
-               x11-libs/libXrender
-               x11-libs/libXtst
-       )"
-
-PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
-       nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
-
-S="${WORKDIR}/jdk-${MY_PV}"
-
-src_install() {
-       local dest="/opt/${P}"
-       local ddest="${ED}${dest#/}"
-
-       # Not sure why they bundle this as it's commonly available and they
-       # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
-       # also has an explicit dependency while Oracle seemingly dlopens it.
-       rm -vf lib/libfreetype.so || die
-
-       # Oracle and IcedTea have libjsoundalsa.so depending on
-       # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
-       if ! use alsa ; then
-               rm -v lib/libjsound.* || die
-       fi
-
-       if ! use examples ; then
-               rm -vr demo/ || die
-       fi
-
-       if use headless-awt ; then
-               rm -v lib/lib*{[jx]awt,splashscreen}* || die
-       fi
-
-       if ! use source ; then
-               rm -v lib/src.zip || die
-       fi
-
-       dodir "${dest}"
-       cp -pPR * "${ddest}" || die
-
-       use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
-       java-vm_set-pax-markings "${ddest}"
-       java-vm_revdep-mask
-       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
-       java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/opt/${P}."
-       fi
-}