net-wireless/iwd: new kernel option & module required
authorBen Kohler <bkohler@gentoo.org>
Thu, 24 Jan 2019 16:19:56 +0000 (10:19 -0600)
committerBen Kohler <bkohler@gentoo.org>
Thu, 24 Jan 2019 16:21:57 +0000 (10:21 -0600)
Check for new PKCS8_PRIVATE_KEY_PARSER option, and also install the new
modules-load.d file for it in case it's modular

Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-9999.ebuild

index 59cf2d5b03ad6bdff4396e132426eed67001ddb4..542d347128bcc96606a7efd620ea4388f46ed640 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -66,6 +66,10 @@ pkg_pretend() {
                WARNING_CRYPTO_SHA512_SSSE3="CRYPTO_SHA512_SSSE3: enable for increased performance"
        fi
 
+       if use kernel_linux && kernel_is -ge 4 20; then
+               CONFIG_CHECK="${CONFIG_CHECK} ~PKCS8_PRIVATE_KEY_PARSER"
+       fi
+
        check_extra_config
 }
 
@@ -90,7 +94,8 @@ src_configure() {
                $(use_enable ofono) \
                $(use_enable wired) \
                --enable-systemd-service \
-               --with-systemd-unitdir="$(systemd_get_systemunitdir)"
+               --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
+               --with-systemd-modloaddir=$(_systemd_get_dir modulesloaddir /usr/lib/modules-load.d)
 }
 
 src_install() {