dev-util/squashmerge: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 5 Jan 2020 14:50:05 +0000 (15:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 5 Jan 2020 15:17:55 +0000 (16:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/squashmerge/squashmerge-0.1.ebuild
dev-util/squashmerge/squashmerge-9999.ebuild

index d4fc299daefaef2e5638be7bf684b0dd40f2beda..b85491ed94273fe313b8f8fabae6b7272f093718 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-
-inherit autotools-utils
+EAPI=7
 
 DESCRIPTION="dev-util/squashdelta delta merge tool"
 HOMEPAGE="https://github.com/mgorny/squashmerge/"
@@ -13,6 +11,8 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
 
 COMMON_DEPEND="
        lz4? ( app-arch/lz4:0= )
@@ -21,16 +21,13 @@ RDEPEND="${COMMON_DEPEND}
        dev-util/xdelta:3"
 DEPEND=${COMMON_DEPEND}
 
-# SquashDelta does not make much sense without a compression algo.
-REQUIRED_USE="|| ( lz4 lzo )"
-
 DOCS=( FORMAT )
 
 src_configure() {
-       local myeconfargs=(
+       local myconf=(
                $(use_enable lz4)
                $(use_enable lzo)
        )
 
-       autotools-utils_src_configure
+       econf "${myconf[@]}"
 }
index 14b136be61846d86df7881d3ce32f2f2b4b20952..3c0238bf3d47dbd5ca62dfcb5c1b62dbc559948a 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
 inherit autotools git-r3
@@ -14,6 +14,8 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
 IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
 
 COMMON_DEPEND="
        lz4? ( app-arch/lz4:0= )
@@ -22,9 +24,6 @@ RDEPEND="${COMMON_DEPEND}
        dev-util/xdelta:3"
 DEPEND=${COMMON_DEPEND}
 
-# SquashDelta does not make much sense without a compression algo.
-REQUIRED_USE="|| ( lz4 lzo )"
-
 DOCS=( FORMAT )
 
 src_prepare() {