sys-libs/libcxx: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:22 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:54 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxx/libcxx-10.0.0.9999.ebuild
sys-libs/libcxx/libcxx-9.0.0.9999.ebuild

index e1be8141143bd36a158bd52d1e82721be5ad7830..04b405e517ea710808390d71aaba3fc751f803e8 100644 (file)
@@ -46,10 +46,10 @@ RDEPEND="
 # clang-3.9.0 installs necessary target symlinks unconditionally
 # which removes the need for MULTILIB_USEDEP
 DEPEND="${RDEPEND}
-       test? ( >=sys-devel/clang-3.9.0
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )
-       app-arch/xz-utils
        >=sys-devel/llvm-6"
+BDEPEND="
+       test? ( >=sys-devel/clang-3.9.0
+               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
 
 DOCS=( CREDITS.TXT )
 
index 4240c6da335617d5e12f29d38aaf6dc4652fd8a9..2b9a0e1433d57cc7f861a477c2865acc46a3da0a 100644 (file)
@@ -47,10 +47,10 @@ RDEPEND="
 # clang-3.9.0 installs necessary target symlinks unconditionally
 # which removes the need for MULTILIB_USEDEP
 DEPEND="${RDEPEND}
-       test? ( >=sys-devel/clang-3.9.0
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )
-       app-arch/xz-utils
        >=sys-devel/llvm-6"
+BDEPEND="
+       test? ( >=sys-devel/clang-3.9.0
+               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
 
 DOCS=( CREDITS.TXT )