dev-ruby/heredoc_unindent: add ruby26
authorHans de Graaff <graaff@gentoo.org>
Mon, 28 Jan 2019 21:03:10 +0000 (22:03 +0100)
committerHans de Graaff <graaff@gentoo.org>
Mon, 28 Jan 2019 21:45:20 +0000 (22:45 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild

index 3697dee1b3e119f1cc32f5962d0b2bee715199c0..a46c76b36a6dcdc590d2f04fb7e63e749c483f3b 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
 
 inherit ruby-fakegem
 
@@ -17,8 +17,12 @@ SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 IUSE="doc test"
 
-ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
 
 all_ruby_prepare() {
        sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
 }
+
+each_ruby_test() {
+       ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}