Version bump. Dependency and ebuild cleanups: bug 149320, thanks to Frederik Holljen.
authorTiziano Müller <dev-zero@gentoo.org>
Wed, 8 Nov 2006 19:34:31 +0000 (19:34 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Wed, 8 Nov 2006 19:34:31 +0000 (19:34 +0000)
Package-Manager: portage-2.1.2_rc1-r1

dev-db/pygresql/ChangeLog
dev-db/pygresql/files/digest-pygresql-3.8.1 [new file with mode: 0644]
dev-db/pygresql/pygresql-3.5.ebuild
dev-db/pygresql/pygresql-3.6.2-r1.ebuild
dev-db/pygresql/pygresql-3.6.2.ebuild
dev-db/pygresql/pygresql-3.8.1.ebuild [new file with mode: 0644]

index a8a9017e3ac5dec2714ccef0b9c71cb238863ec6..f947c076dc62bc688bedb6900167a547f008eb1d 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for dev-db/pygresql
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.36 2006/04/27 15:10:40 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.37 2006/11/08 19:34:31 dev-zero Exp $
+
+*pygresql-3.8.1 (08 Nov 2006)
+
+  08 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
+  -files/pygresql-3.6.1-gentoo.patch, pygresql-3.5.ebuild,
+  -pygresql-3.6.1.ebuild, pygresql-3.6.2.ebuild, pygresql-3.6.2-r1.ebuild,
+  -pygresql-3.8.ebuild, +pygresql-3.8.1.ebuild:
+  Version bump. Dependency and ebuild cleanups: bug 149320, thanks to Frederik
+  Holljen.
 
   27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-pygresql-3.5,
   files/digest-pygresql-3.6.1, files/digest-pygresql-3.6.2,
diff --git a/dev-db/pygresql/files/digest-pygresql-3.8.1 b/dev-db/pygresql/files/digest-pygresql-3.8.1
new file mode 100644 (file)
index 0000000..735807f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz 81186
+RMD160 67945cb75dd0fbad4c1dac2e606e10f6cdde7002 PyGreSQL-3.8.1.tgz 81186
+SHA256 5638e1f12c8dd4f1ea8c9db4f92a98d19e66dbef2e25ab45ede190c3fcac816d PyGreSQL-3.8.1.tgz 81186
index c088992d46582d79b881f13963d06b7b40b2a334..9f760a4161b3c3d1dbb292c8a607cf6c87bda759 100644 (file)
@@ -1,24 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.5.ebuild,v 1.8 2005/02/06 20:51:25 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.5.ebuild,v 1.9 2006/11/08 19:34:31 dev-zero Exp $
 
 inherit eutils distutils
 
+KEYWORDS="x86 ~ppc sparc alpha amd64 hppa ~ia64 mips"
+
 MY_P="PyGreSQL-${PV}"
-DESCRIPTION="a Python interface for PostgreSQL database."
-SRC_URI="ftp://ftp.druid.net/pub/distrib/${MY_P}.tgz"
-HOMEPAGE="http://www.druid.net/pygresql/"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
 LICENSE="as-is"
-DEPEND=">=dev-db/postgresql-7.3
-       dev-lang/python"
-KEYWORDS="x86 ~ppc sparc alpha amd64 hppa ~ia64 mips"
-IUSE=""
 SLOT="0"
+IUSE=""
 
-S="${WORKDIR}/${MY_P}"
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}
+               dev-python/egenix-mx-base"
+
+S=${WORKDIR}/${MY_P}
 
 src_unpack() {
        unpack ${A}
-       epatch ${FILESDIR}/${P}-gentoo.patch
+       epatch "${FILESDIR}/${P}-gentoo.patch"
 }
-
index beef9cf53f2b2317b9f3c4de4964db73c2c9ea96..7c10c5395b259e9e6fa0c6875819285eccf6608e 100644 (file)
@@ -1,24 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.6.2-r1.ebuild,v 1.1 2005/05/09 00:33:35 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.6.2-r1.ebuild,v 1.2 2006/11/08 19:34:31 dev-zero Exp $
 
 inherit eutils distutils
 
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~hppa ~ia64 ~mips"
+
 MY_P="PyGreSQL-${PV}"
-DESCRIPTION="a Python interface for PostgreSQL database."
-SRC_URI="ftp://ftp.druid.net/pub/distrib/${MY_P}.tgz"
-HOMEPAGE="http://www.druid.net/pygresql/"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
 LICENSE="as-is"
-DEPEND="dev-db/libpq
-       dev-lang/python"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~hppa ~ia64 ~mips"
-IUSE=""
 SLOT="0"
+IUSE=""
 
-S="${WORKDIR}/${MY_P}"
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}
+               dev-python/egenix-mx-base"
+
+S=${WORKDIR}/${MY_P}
 
 src_unpack() {
        unpack ${A}
-       epatch ${FILESDIR}/${P}-gentoo.patch
+       epatch "${FILESDIR}/${P}-gentoo.patch"
 }
-
index f8740c1aa582ad64d224f8b36545e86a03dbcbf4..535311c34e7f555866eb42773d272f11921e6d3f 100644 (file)
@@ -1,24 +1,27 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.6.2.ebuild,v 1.8 2006/02/06 19:37:14 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.6.2.ebuild,v 1.9 2006/11/08 19:34:31 dev-zero Exp $
 
 inherit eutils distutils
 
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
+
 MY_P="PyGreSQL-${PV}"
-DESCRIPTION="a Python interface for PostgreSQL database."
-SRC_URI="ftp://ftp.druid.net/pub/distrib/${MY_P}.tgz"
-HOMEPAGE="http://www.druid.net/pygresql/"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
 LICENSE="as-is"
-DEPEND=">=dev-db/postgresql-7.3
-       dev-lang/python"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
-IUSE=""
 SLOT="0"
+IUSE=""
 
-S="${WORKDIR}/${MY_P}"
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}
+               dev-python/egenix-mx-base"
+
+S=${WORKDIR}/${MY_P}
 
 src_unpack() {
        unpack ${A}
-       epatch ${FILESDIR}/${P}-gentoo.patch
+       epatch "${FILESDIR}/${P}-gentoo.patch"
 }
-
diff --git a/dev-db/pygresql/pygresql-3.8.1.ebuild b/dev-db/pygresql/pygresql-3.8.1.ebuild
new file mode 100644 (file)
index 0000000..a7114d4
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-3.8.1.ebuild,v 1.1 2006/11/08 19:34:31 dev-zero Exp $
+
+inherit eutils distutils
+
+KEYWORDS="~sparc ~x86"
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
+LICENSE="as-is"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-db/libpq"
+RDEPEND="${DEPEND}
+               dev-python/egenix-mx-base"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+       distutils_src_install
+
+       dodoc docs/*.txt
+
+       if use doc ; then
+               insinto /usr/share/doc/${PF}/tutorial
+               doins tutorial/*
+               dohtml docs/*.{html,css}
+       fi
+}