sys-fs/fatsort: Version bump to 1.5.0. Switch to EAPI 7.
authorDaniel Pielmeier <billie@gentoo.org>
Sun, 7 Oct 2018 14:28:17 +0000 (16:28 +0200)
committerDaniel Pielmeier <billie@gentoo.org>
Sun, 7 Oct 2018 14:28:42 +0000 (16:28 +0200)
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

sys-fs/fatsort/Manifest
sys-fs/fatsort/fatsort-1.5.0.ebuild [new file with mode: 0644]

index a556760e4272cd0a7dba4e7cab285dee5d8e08fb..3f97b2b9d9b76a9259926cddd6d7b04f1ce40437 100644 (file)
@@ -1 +1,2 @@
 DIST fatsort-1.4.2.439.tar.xz 41852 BLAKE2B 30ffc8575ca50a71c09c5f90e658a150ece34a9bed664696d8969ccbe4c3cb1b0130d830990e259889fab331ccf0c35e3f0aa3401628fdff3e04acbb7d0b53dd SHA512 c51b5316b34e1a74e2a8d1c625716fd022d32e40a92ef56b88fbc940b5e6dd6c978b733f180477e8b5b3235b46cd16eb74798c5aadd45de9ead1f1bafdf52fee
+DIST fatsort-1.5.0.456.tar.xz 56100 BLAKE2B 996f144c67a2311ef9962b06e776d0a0c8897814383e50c9f48f5af0bc800159ee34c10d9f8d51dae5160844dfe9fcbc4b56bb9883cbdb0402a0ea20198fc1d6 SHA512 fe9d8108494fd64da730ec40882582fc16a89e76a5ba4e8040d03a3dbbf12c525904abe24814337713f5f1d15c72e8321b27fad69db816c073a96fbfd15ea486
diff --git a/sys-fs/fatsort/fatsort-1.5.0.ebuild b/sys-fs/fatsort/fatsort-1.5.0.ebuild
new file mode 100644 (file)
index 0000000..5568264
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+SVN_REV=456
+MY_P=${P}.${SVN_REV}
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+
+       sed -i -e '/^\(MANDIR=\|SBINDIR=\)/s|/usr/local|/usr|' \
+               $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+       emake CC=$(tc-getCC) LD=$(tc-getCC) \
+               CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+               DESTDIR="${D}"
+}
+
+src_test() {
+       # Tests require root permissions and mounting filesystems which does
+       # not work inside the ebuild environment
+       true
+}