dev-python/croniter: 0.3.29 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Apr 2019 20:59:49 +0000 (15:59 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 12 Apr 2019 22:46:55 +0000 (17:46 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/croniter/Manifest
dev-python/croniter/croniter-0.3.29.ebuild [new file with mode: 0644]

index 3d162ef2faf5a75137c2976a9f05e91e883f7ead..f7bff104cdedd87fcaf4c85d5a7928a506397019 100644 (file)
@@ -1 +1,2 @@
 DIST croniter-0.3.17.tar.gz 17362 BLAKE2B 59887df1cb1464046612fd87bf82575355361b9baa934817d92ea17ded6a440100015168d7622952a218d96d6f8d3a568ebdcde85f2a7ddbe8a31a44b201b3b6 SHA512 4215fc7461843cc2c62fca05424d5eb7d0c80c21cc1e637f5ce3c4891da458cd609d6ed501fab7fe244bbb234e9834ec8a12b76289eec10808ed6c30c1b4d45a
+DIST croniter-0.3.29.tar.gz 20276 BLAKE2B 951b9f2e998be496420dbf08e06a60a0eb3eb8538d9e63bf11182bc449bc49eaec36c1d1025269974fd0ff24430e16c3cf410d2b50873498d077ac22e0b52fb8 SHA512 0333e8d801aa7453ea6bc2b49abcabb24390535eecb5af2050512cf69410d21179405ceea14b8037c8f107321ee53a10c6060796c86c9b24ae48af65068e9b87
diff --git a/dev-python/croniter/croniter-0.3.29.ebuild b/dev-python/croniter/croniter-0.3.29.ebuild
new file mode 100644 (file)
index 0000000..f276889
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+       )"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+python_test() {
+       py.test -v src/croniter/tests || die "tests failed"
+}