app-emulation/aqemu: revbump; add sec. patch
authorIan Delaney <idella4@gentoo.org>
Wed, 19 Aug 2015 02:06:59 +0000 (10:06 +0800)
committerIan Delaney <idella4@gentoo.org>
Wed, 19 Aug 2015 02:07:28 +0000 (10:07 +0800)
submitted by René Rhéaume via sec. bug #521026

Package-Manager: portage-2.2.20

app-emulation/aqemu/aqemu-0.8.2-r3.ebuild [new file with mode: 0644]
app-emulation/aqemu/files/aqemu-0.8.2_format-security.patch [new file with mode: 0644]

diff --git a/app-emulation/aqemu/aqemu-0.8.2-r3.ebuild b/app-emulation/aqemu/aqemu-0.8.2-r3.ebuild
new file mode 100644 (file)
index 0000000..688670f
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit  cmake-utils
+
+DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt4"
+HOMEPAGE="http://sourceforge.net/projects/aqemu"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vnc"
+
+DEPEND="${RDEPEND}"
+RDEPEND="app-emulation/qemu
+       vnc? ( net-libs/libvncserver )
+       dev-qt/qtgui:4
+       dev-qt/qttest:4
+       dev-qt/qtxmlpatterns:4"
+
+DOCS="AUTHORS CHANGELOG README TODO"
+
+PATCHES=(
+       "${FILESDIR}"/aqemu-0.8.2_sigsev_propertis.patch
+       "${FILESDIR}"/aqemu-0.8.2_qt48_build.patch
+       "${FILESDIR}"/aqemu-0.8.2_desktop_file.patch
+       "${FILESDIR}"/aqemu-0.8.2_format-security.patch
+)
+
+src_configure() {
+       local mycmakeargs=(
+               "-DMAN_PAGE_COMPRESSOR="
+               "-DWITHOUT_EMBEDDED_DISPLAY=$(use vnc && echo "OFF" || echo "ON")"
+       )
+
+       cmake-utils_src_configure
+}
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_format-security.patch b/app-emulation/aqemu/files/aqemu-0.8.2_format-security.patch
new file mode 100644 (file)
index 0000000..d6ce939
--- /dev/null
@@ -0,0 +1,38 @@
+--- aqemu-0.8.2-orig/Utils.cpp
++++ aqemu-0.8.2-format-security/Utils.cpp
+@@ -66,9 +66,9 @@ void AQDebug( const QString &sender, con
+               std::cout << QString( "\nAQEMU Debug [%1] >>>\nSender: %2\nMessage: %3" )
+                                                         .arg(Messages_Index).arg(sender).arg(mes).toStdString();
+       #else
+-              qDebug( qPrintable(QString(
++              qDebug() << qPrintable(QString(
+                       "\n\33[32mAQEMU Debug\33[0m [%1] >>>\n\33[32mSender:\33[0m %2\n\33[32mMessage:\33[0m %3")
+-                      .arg(Messages_Index).arg(sender).arg(mes)) );
++                      .arg(Messages_Index).arg(sender).arg(mes));
+       #endif
+       }
+       
+@@ -87,9 +87,9 @@ void AQWarning( const QString &sender, c
+               std::cout << QString( "\nAQEMU Warning [%1] >>>\nSender: %2\nMessage: %3" )
+                                                         .arg(Messages_Index).arg(sender).arg(mes).toStdString();
+       #else
+-              qDebug( qPrintable(QString(
++              qDebug() << qPrintable(QString(
+                       "\n\33[34mAQEMU Warning\33[0m [%1] >>>\n\33[34mSender:\33[0m %2\n\33[34mMessage:\33[0m %3")
+-                      .arg(Messages_Index).arg(sender).arg(mes)) );
++                      .arg(Messages_Index).arg(sender).arg(mes));
+       #endif
+       }
+       
+@@ -108,9 +108,9 @@ void AQError( const QString &sender, con
+               std::cout << QString( "\nAQEMU Error [%1] >>>\nSender: %2\nMessage: %3" )
+                                                         .arg(Messages_Index).arg(sender).arg(mes).toStdString();
+       #else
+-              qDebug( qPrintable(QString(
++              qDebug() << qPrintable(QString(
+                       "\n\33[31mAQEMU Error\33[0m [%1] >>>\n\33[31mSender:\33[0m %2\n\33[31mMessage:\33[0m %3")
+-                      .arg(Messages_Index).arg(sender).arg(mes)) );
++                      .arg(Messages_Index).arg(sender).arg(mes));
+       #endif
+       }
+